Nouvelle version 4.7 : Affichage graphique et mise à jour majeure de l'intégration Zigbee2mqtt!

Salut à tous !

Après des mois de travail, je suis heureux de lancer aujourd’hui Gladys Assistant v4.7 (techniquement, Gladys Assistant v4.7.1), une mise à jour assez importante avec 2 principales nouveautés :

  • La vue “graphique” sur le tableau de bord
  • Une mise à jour majeure de Zigbee2mqtt, grâce au super travail de @AlexTrovato.

Pour en savoir plus, j’ai détaillé toutes les nouveautés dans un article sur le blog:

La documentation a été mise à jour aussi: Afficher un graphique sur le tableau de bord | Gladys Assistant

Merci à tous ceux qui ont contribués à cette mise à jour :pray:

Je pense à @AlexTrovato, @VonOx, @bertrandda et @Pti_Nico !

4 Likes

Petite interrogation au passage : pourquoi 100 valeurs ?
128 me semblent plus appropriés à un système informatique, optimisation gratuite au passage.
Avec l’avantage sur une journée de faire 10 valeurs par heure. :wink:

Et pourquoi pas? :slight_smile:

La valeur a été choisie visuellement (et un peu arbitrairement aussi), 100 valeurs sur un graphique c’est vraiment la limite à partir duquel ça sert pas à grand chose d’ajouter des valeurs.

128 ça aurait été trop à mon avis, et 64 trop peu ^^ Sachant que ça n’apporte pas d’optimisation de mettre 128, au contraire mieux vaut mettre la valeur la plus faible possible sans que ça dégrade l’affichage.

La suppression d’un device dans zigbee2mqtt est extrêmement long. Celà met mon Gladys en PLS :frowning: et dans la partie configuration çà met " gladys ne s’execute pas dans docker. Il est impossible d’activer zigbee2mqtt depuis gladys. Plus d’accès au dashboard possible.

Au bout de 5 min suppression effective …

Tu as quel modèle de raspberry ?

un raspberry 3. J’avais pas ce soucis avant

Pas de soucis sous RPi 4 en tout cas. Même s’il est un peu plus puissant, ça me surprend que l’on passe de moins d’une seconde à quelques minutes :confused:

et voilà un autre problème lié à la suppressin j’ai un device que je peux plus recréé sous gladys j’ai:

“Une erreur s’est produite lors de la sauvegarde”.

J’ai tenté un docker logs -f --since 1m gladys mais je vois rien
Je pense qu’il est encore présent dans une table de la BDD mais bon j’ai pas ( encore ) les connaissances pour y accéder et modifier.

Autre problème l’intégration d’un device a complètement disparu:
(Zigbee2mqttManager.handleMqttMessage) Zigbee2mqtt device 0x5c0272fffe8f7bca not configured in Gladys." ( le Heiman )

Bizarre! Tu es sûr que le problème vient spécifiquement de cette action, où c’est juste ton instance qui est lente de manière générale ?

  • Tu tournes sur une carte SD ? Ta carte SD est pas trop vieille ?
  • Tu fais tourner d’autres logiciels que Gladys ?

@AlexTrovato ça te dit quelque chose?

Petite question:
Si je repars sur une installation fraîche de Gladys depuis l’image officielle, je serai sur Buster ou Bullseye?
Belle soirée!

oui je suis carteSD. Je sais plus de quand elle date mais elle tourne que depuis juin. Mais bon je compte passé en SSD dès que j’aurais 5 mins.
non c’est une installation spécialement pour gladys.

Pour la lenteur, c’est surement la carte qui montre des faiblesses, par contre je vais un autre topic pour demander de l’aide pour modifier mes devices fantômes.

Niet.

Ça me fait penser à une feature “système” évoquée il y a quelques mois, justement pour avoir la main sur les devices en DB de manière plus “brute”.

Buster

Mais si tu te sent de tester on a fait un build bullseye

Hésite pas à donner un feedback ici Gladys SD Image Evolution to Debian 11 "Bullseye" · Issue #5 · GladysAssistant/gladys-pi-gen · GitHub

2 Likes

Bonjour,

je reviens car je viens de faire un test et une intégration d’un device bug.
J’arrive plus à sauvegarder sous gladys “decouverte zigbee” le device détecteur de mouvement RTCGQ11LM. Mon ancien device ne se sauvegarde plus et un nouveau device RTCGQ11LM aussi.

erreur: “Une erreur s’est produite lors de la sauvegarde.”

intégration ok dans le gladys8080

J’ai peut être pas de chance et le secteur de ma carte SD est défectueux sur l’endroit ou est stocké l’enregistrement des devices RTCGQ11LM.

par contre un capteur de température WSDCGQ11LM est bien sauvegardé sous Gladys.

De plus j’ai aussi perdu l’intégration de mon détecteur de monoxyde de carbon HS1CA-E

@mikael Je pense vraiment que tout ça provient de ta carte SD défectueuse, tout ça n’a rien de normal ^^

@pierre-gilles : c’est bon le problème vient d’être cerné: Conflict lors de l'ajout d'un device Z2M - #3 by Albenss

cela change rien que je vais devoir basculé sur SSD pour plus de sécurité.

Top! De retour de vacances, je regarde toute les PR demain :slight_smile:

J’ai vu que @AlexTrovato avait fait une PR pour corriger ça:

bonsoir
je touves les graphiques superbe et utils tant les températures humidités et consos

par contre j’ai une idée ou demande , j’aimerais connaitre le nombre de fois et la durée que ma chaudière s’allume genre un contact on off on enregistre quand c’est “on” puis quand c’est “off” et affichage genre barre graphe durée de fonctionnement d’un appareil on peut imaginer utiliser les inters sonof par exemple ?

Merci @pascal_sapin ça fait toujours plaisir les retours positifs :slight_smile:

C’est une demande qui a été faite, tu peux mettre un vote ici si tu veux encourager le développement :

exactement ça , une vue événement avec le choix des appareils a suivre dans un temps voulu ,24 heures plusieurs jours voir même mois
à suivre