Problème détection de ma présence

Bonjour à tous. J’ai un soucis pour la détection de ma présence. J’ai installé 2 itag, un pour moi et un pour ma compagne J’ai crée les scènes de présence et de départ avec les même délais pour chacun. Ca fonctionne très bien pour ma compagne et pour moi impossible d’être noté absent sur le Dashboard . Toutes les 2 min Gladys vérifie la présence de l’itag de chacun depuis les 5 dernières min. J’ai essayé plusieurs itag pour moi et ça ne change rien. J’en viens à me demander si le fait que je soit l’administrateur et connecté à Gladys je ne soit pas considéré présent par défaut. Peux être faut il que je crée un nouvel utilisateur juste pour la détection de ma présence?

bonjour, j’ai créé un nouveau simple utilisateur j’ai rien changé aux scènes, juste le prénom puisque 2 utilisateurs ne peuvent pas avoir le même prénom. Et hop tout fonctionne. Quelqu’un peu me confirmer que la détection de présence ne fonctionne qu’avec un simple utilisateur. Si c’est le cas je vais devoir modifier les identifiants de mon compte administrateur pour récupérer mon prénom pour le fonctionnement quotidien (scènes, présence).Et surement aussi modifier des choses pour Gladys +.

Salut!
Désolé mais je n’ai pas ce problème alors que je suis bien admin.
Détection avec badge ou owntracks.
Le problème doit venir d’ailleurs…
Il faudra attendre un spécialiste pour investiguer ça :wink:

1 Like

Méa culpa, :pleading_face: pas besoin d’un spécialiste, je viens de trouver le problème. Lorsque j’ai créé mon compte j’ai écris mon nom et mon prénom sans majuscule et sans accent et le sélecteur utilisateur s’est écrit sans lui aussi. Depuis j’ai corrigé tout ça mais le sélecteur lui ne s’est pas corrigé. Je me retrouvais avec des prénoms écrit de différente façons dans mes scènes. Se qui me chagrine c’est qu’apparemment on ne peut pas corriger le sélecteur utilisateur. Et supprimer le compte administrateur pour le recréer correctement non plus .J’ai donc mon prénom sans majuscule et sans accent partout "frederic).Si il y a une façon caché de corriger le sélecteur je suis preneur. Merci GBOULVIN pour ton retour.

2 Likes

Modifier en bdd mais uniquement pour les utilisateurs qui savent ce qu’ils font.
Sinon peut etre créer une issue sur github en expliquant bien ton cas et le moyens de reproduire.
Ajoute un lien vers ce post et peut etre que @pierre-gilles aura le temps de check et corriger

1 Like

Effectivement, le selector est une variable à usage interne/API qui n’est pas modifiable une fois créée, par contre de toute façon le selector n’aura pas d’accent, ni d’espace, ni de majuscule, c’est un « slug » utilisée dans l’API et qui doit être URL compatible.

Je ne recommande pas d’aller en DB le modifier, c’est le meilleur moyen d’avoir un slug non valide et d’oublier d’aller le mettre à jour partout où il est utilisé (scènes notamment).

Quand tu dis « partout », c’est où ? « frederic » est un selector tout à fait normal, il n’y a rien à changer :slight_smile:

Bonsoir, Pour le sélecteur je comprends, mais j’ai dû retirer la majuscule et les accents de mon prénom dans mon profil ou l’on doit renseigner nom et prénom. Avant ça ma scène de présence ne fonctionnait pas. Et donc maintenant lorsque je me connecte sur mon compte administrateur en haut à droite j’ai mon prénom sans accent et majuscule et là c’est pas le sélecteur il me semble c’est le prénom de mon profil. Ce que je ne comprends pas c’est pourquoi j’ai dû retirer les accents et la majuscule de mon prénom pour ma scène fonctionne. Comme tu peux sur la photo de ma tablette le nom d’utilisateur de ma voiture c’est sandéro avec un accent et là la scène fonctionne.

Je ne pense pas qu’il y ait de lien entre fonctionnement d’une scène et accent dans le nom de ton profil ^^

Est-ce que tu peux remettre les accents dans ton profil, et si jamais tu rencontre une erreur nous la partager ici ?