Zigbee2mqtt problème de connexion depuis nouvelle version

bonjour
je n’arrive plus a accéder à l’interface zigbee2mqtt port 8080
mes capteurs de mouvement fonctionnent bizarre

image
le conteneur dis redémarrage mais rien ne bouge

dans la config la connection ne se fait pas

La solution est ici, si c’est le même problème que beaucoup de monde suite à une mise à jours de Zigbee2mqtt.

humm , merci
mais bon pour moi ce n’es pas compréhensible pour la solution ?
désolé pas très Friendly user

Pour pouvoir effectuer la manipulation, il faut que tu te connectes en SSH à ta machine (un Raspberry Pi peut être ?).
Une fois connecté tu pourras bêtement copier / coller les commandes mises en lien, une après l’autre.

Si tu as besoin d’aide n’hésite pas ! :+1:

hum , oui je vois je suis sur un raspi3
mais quand je vois les kilomètres de paramétrages, je laisse tomber , je vais viré le systeme ziegbee je crois.

Ah ben si tu envisages de le virer c’est que tu n’en as pas l’utilité j’imagine… Donc c’est pas plus mal.
Pour autant il n’y a pas de kilomètres de choses à faire.
4 lignes à copier / coller, c’est faisable même si c’est pas le plus intuitif.

si, j’en ai utilité , mais pour moi sa doit resté simple et pas une usine à gaz , lol, pour info j’ai commencé la télégestion en 1986 , je pensais qu’on avait progressé, mais la, faut être informaticien pour arriver a faire fonctionner le moindre noeuds HI
si je perds plus de temps dans le paramétrage et l’entretien et le fonctionnement, à part être un geek ce que j’étais mais ne suis plus je laisse tomber, c’est amusent un moment mais après bof…

Je comprends ce que tu dis, si je t’ai répondu comme ça c’est pour plusieurs raisons :

  • si tu veux du super stable avec toutes les intégrations (notamment Zigbee2mqtt) déjà à un stade avancé, alors Gladys n’était peut être pas le meilleur choix. C’est un projet en développement, qui avance à son rythme.
  • les choses à copier / coller ne sont pas du ressort de Gladys mais de Zigbee2mqtt, donc quelque soit la plate-forme le problème reste le même.

Je te rejoins sur le fait que l’idéal c’est de ne JAMAIS avoir à intervenir de la sorte :ok_hand:

Yes, c’est sur, bon ne le prends pas mal suis un peut sur nerfs, en général je m’en sorts toujour, mais bon avec l’expérience je me dis que tout les efforts à faire pour faire fonctionner quelques choses de simple, allumer une lampe lol.
En tout. Cas merci à toute l’équipe du projet très réactif.

1 Like

Ou prendre la dernière image gladys raspberry bullseye qui n’a pas ce problème.

Et tout réinstaller ?
Dois-je comprendre que sans cette version le problème persistera ?

Oui

Oui il manque une dépendance système, nécessaire pour zigbee2mqtt ( le problème n’est pas côté gladys)
Donc tu ne veux pas tout réinstaller, il faut installer le package en question. ( ce qu’a détailler @guim31)

Ce genre de chose arrivera encore, le projet zigbee2mqtt est indépendant et nous ne pouvons pas anticiper ce genre de changement.


En 3 étapes le problème est réglé ( c’est l’occasion d’apprendre des choses :wink:)

  1. La première pour “ouvrir un terminal à distance sur ton pi”

ssh pi@192.168.1.1 Remplace par l’adresse ip de ton pi, le mot de passe raspberry sera demandé

  1. Une fois connecté en ssh on execute les 4 commandes détaillées dans la solution:
sudo apt-key adv --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys 04EE7237B7D453EC 648ACFD622F3D138
echo "deb http://httpredir.debian.org/debian buster-backports main contrib non-free" | sudo tee -a "/etc/apt/sources.list.d/debian-backports.list"
sudo apt update
sudo apt install libseccomp2 -t buster-backports
  1. On redémarre le pi

sudo reboot

1 Like

Bonsoir VonOx,
c’est valable pour la nouvelle image Gladys “gladys-os-rpi-rev5” ?

Je sais pas a quoi correspond la rev 5, si c’est la dernière image debian bullseye non ( l’image est daté du 29/03/22)

c’est la dernière version, celle que l’on trouve sur le tuto d’install de Gladys sur RPI de Pierre-Gilles
"gladys-os-rpi-rev5 " c’est le nom de l’image de Gladys
merci pour ta réponse :slightly_smiling_face:

Dans ce cas oui tu es concerné

Toujours prendre la dernière version sur le site les liens ne so t pas forcément à jour en fonction de la date de rédaction du tuto.

Je pose le lien si d’autres passent par ici

Suite au problème de ziegbee2mqtt réglé hier pour moi je me suis dit qu’il était peut-être bien de passer à la version 64 bit avant d’accumuler d’autres périphériques.
Je me lance donc dans les captures d’écran des scènes et autre paramètres et j’exporte mon flow Node-red.

Je constate que Node-red me propose 2 mises à jour node-red-dashboard et node-red-node-serialport
Capture d’écran du 2022-04-04 00-02-51

J’effectue la mise à jour du dashboard je relance le Raspberry tout va bien je fais la mise à jour de serialport je relance le Raspberry et le n’arrive plus à me connecter à node-red, le docker redémarre toutes les 30 secondes.

J’avais fait une sauvegarde de ma carte SD hier, donc je l’ai restauré ainsi pas de soucis pour moi.

Mais faites attention si vous effectuer cette mise à jour.

Je penses que t’aurai du mettre à jour avant l’import des flow

Pareil pour moi,
VonOx j’ai installé la version de Gladys que tu indiques. au bout de 6 fois de reinstall, je constate que si je restaure Gladys avec sauvegarde Gladys +, avant d’installer NodeRed, tous les services de Gladys s’installent et fonctionnent correctement, puis je charge Node red tout va bien , je reinstalle mes palettes (qui elles ne sont pas dans la sauvegarde de node red, je restaure mes flows tout se charge correctement, mais après" perte de connexion au serveur “, je n’ai plus de connexion de la gateway Xiaomi , plus de connexion Mqtt. Et en passant il ne faut pas oublier de réinitialiser le broker Mqtt de Gladys, (car il ne redémarre pas tout seul). Et quand je relance Node red je n’ai plus de connexion au dashboard de Node RED( IpGladys:1880). Oui j’ai aussi le redémarrage de Node Red en boucle, moi tous les 15secondes environ (ça me rappelle mon problème avec Zigbbe2Mqtt. " il semble que le container reboote toutes les 20 secondes environ.”)
koenkk/zigbee2mqtt:latest “docker-entrypoint.s…” 12 days ago Up 18 seconds gladys-z2m-zigbee2mqtt
koenkk/zigbee2mqtt:latest “docker-entrypoint.s…” 12 days ago Up 18 seconds gladys-z2m-zigbee2mqtt
koenkk/zigbee2mqtt:latest “docker-entrypoint.s…” 12 days ago Up 1 second gladys-z2m-zigbee2mqtt``)

Et en vérifiant, je me rend compte que gladys-z2m-zigbee2mqtt, boucle également lui toutes les 30 secondes
C’est grave docteur?

Hello, bon ben voila c’est reparti tout refonctionne, juste un capteur que j’ai du reapairé, détecteur de fuite, merci pour l’aide, j’ai lancer toutes les commandes même si je sais pas trop à quoi sa correspond ni ce que sa fait, c’est aussi cela qui me fait peur lol