[BETA] App Android

beta

#181

Wow et moi je suis passer a coté aussi sur ta vidéo ! :dizzy_face:
Les nuls :joy:

Tant mieux que tu t’en sois sorti !


#182

C’était même 196.168 que t’avais mis :wink:


#183

Possible ^^ je la note tellement souvent cette ip en plus… Je suis Très distrait !


#184

J’ai mis Gladys en https et maintenant l’app me renvoie une erreur 5 :disappointed_relieved:


#185

Salut @rafi59

Fait nous un screen de tes paramètres dans l’app :wink:


#186

Voici les paramètres


#187

En principe tu peux laisser, le port 8080, l’http fonctionne toujours, je ne pense pas que @LepetitGeek ait géré l’HTTPS sur la partie locale :wink:


#189

Oui c’est exact !
En local l’app ne passe pas par l’HTTPS car c’est inutile pour elle, donc laisse le port 8080 :wink:


#190

Je confirme, j’ai eu le même problème initialement, car il me semblait logique d’interroger Gladys sur le port 443. Mais lors du lancement de gladys, j’ai vu que le processus était configuré sur 8080. Et en utilisant 8080 dans l’appli tout est rentré dans l’ordre.


#191

@LepetitGeek en regardant de plus près tu as noté plus haut que tu n’affichais que les devices qui sont attribués à une pièce je pense qu’il faudrait gérer la condition avec un OU pour afficher le device quand il est associé à un utilisateur.
Parce que par exemple les portes clés Nuts n’ont pas une affectation de pieces précise.

Je me suis quand même amusé à leur assigner des pieces et surprise !! Ils ont un curseur de config ^^’
Ce qui n’est pas du tout pertinent pour un porte clé Bluetooth :joy:

Alors apres tu vas certainement le dire "quel intérêt de voir tes Nuts dans les devices ?! "

Euh… Pour le moment aucun j’avoue ^^’ mais bon on sait jamais :stuck_out_tongue:


#192

Ah oui effectivement… l’app devraient gérer ce genre de cas :thinking:
Mais normalement si tu ne lui avait pas affecté de pièce il ne devrait pas apparaître dans l’app… :sweat_smile:
Et le problème ne vient pas forcement de l’app mais plutôt de la requête utilisée. Cette requête ne renvoi QUE les devices attribué a une pièce donc soit il faudrait voir avec @pierre-gilles pour ajouter cette condition a la requête soit il faudrait faire deux requête différentes dans l’app mais bon j’éviterais de faire ça quand même car niveau performances on va perdre…

Après pour le fait qu’il se retrouve avec une seekbar c’est du au type que tu lui a assigné !


#193

Je dirais deux requêtes, ça me choque pas :slight_smile: la requête de GET de device que tu utilise n’a pas vocation à retourner les pièces de façon exhaustive, mieux vaut que tu passe par un GET /room


#194

Je sais pas trop ça me paraît trop deux requête a gérer :thinking:
Mais je note et je ferais des essai on sait jamais je peux me tromper :slight_smile:
Pour l’instant je suis sur le brain et j’ai pas mal avancé ! J’ai plus qu’à implémenter les fonctions de modification et j’ai quelques trucs à régler a droite a gauche donc j’en profiterais pour tester ça ^^


#195

Je me permets de préciser un point, en plus de ne pas être propre cela risque de supprimer les liaisons des alarmes avec d’éventuels scénarios qui doivent surement être liés aux ID des alarmes.


#196

Oui exact !
Donc il vaut mieux créé une route exprès :wink:


#197

Je viens de voir l’appli, et elle est déjà bien pratique, joli travail.

Une petite remarque, il semble n’y avoir qu’un devicetype avec curseur par device :

Bravo pour cette appli bien pratique :wink:


#198

Merci !
Je comprend pas ce que tu veux dire par la ? :thinking:
Les deviceType affiché sur l’app sont ceux que tu affiché sur Gladys.


#199

Je me suis mal exprimé. Dans Gladys, j’ai ça (j’ai simplifier sur les deviceTypes Britness et Saturation)

Donc les 2 devices Types semblent du même type.

dans Gladys j’ai bien les 2 curseurs pour régler les valeurs.

Sur l’appli mobile, je n’ai le curseur que sur le deviceType Brightness. Sur le devicetype saturation, je récupère la valeur mais je ne peux pas la changer (cf l’image poster précédemment)

J’ai remarquer que même si je ne laisse que l’affichage de saturation uniquement, je n’ai pas non plus le curseur. Celà viendrait-il donc de la configuration du deviceType ?


#200

Alors non ! Ça vient de l’app !
En fait elle catégorise les deviceType selon leurs type, le problème c’est que je ne peux pas prévoir ce que les modules mette comme type (ou même les utilisateur) donc en gros l’app catégorisé ton deviceType comme un sensor car elle ne connaît pas le type “saturation” donc elle en déduit que c’est un sensor et te l’affiche de cette manière :slight_smile:
Je corrige ça dans la prochaine MAJ ! Qui d’ailleurs arrivera sûrement la semaine prochaine ^^


#201

Ok cool, j’attends la mise à jour.
En attendant, cette appli à d’hors et déjà remplacée l’application Mi-Light officielle sur mon smartphone et ma tablette :wink: