[Camera] est-ce un bug?

Bonjour à tous

j’ai très très souvent ce genre d’image dans le tableau de bord

je pensais que c’était parce que le réseau est porté par le CPL…mais VLC s’en sort très bien

image

je crée une issue dans Github ?

bonne journée

hello , bonjour
j’ai la même chose , je penses que c’est un problème de synchronisation , Gladys prends un snap au moment pile d’une transition d’image vidéo
infin bon c’est mon avis

peut être autre chose

J’ai eu la même chose sur une de mes caméra.
Même apres redemarage de celle-ci.
En effectuant un test dans l’intégration caméra, ça tournait en boucle.
Pour ma seconde j’ai eu l’image rapidement.

J’ai du redémarrer encore une fois la camera pour que l’affichage soit bon.

Ca marrive souvent mais effectivement, gladys prend un snap a un instant t il me semble et cest tombé a ce moment la.
Tu ne devrais pas avoir le soucis avec la nouvelle evo que @pierre-gilles développe ( live camera)

Salut @bong101 !

Par curiosité :

  • Quelle fréquence de rafraichissement as-tu sur ta caméra dans Gladys ?
  • Est-ce que ta caméra est « consommé » par d’autres logiciels ?

Pour information on utilise ffmpeg dans Gladys pour aller chercher une image de caméra, et je demande à ffmpeg de faire un « snapshot » de la caméra.

Donc la théorie de @pascal_sapin est plausible, c’est possible que ce soit un problème de timing, la caméra te renvoie une image « entre deux », mais c’est aussi possible que ce soit un bug qui viennent de Gladys/FFmpeg.

Non le live ne changera rien, le live est complémentaire à l’image statique mais Gladys ne consomme pas H24 la caméra par défaut.

Bonjour à tous

Pour répondre à Pierre-Gilles

1/ toutes les minutes

2/ non, pas d’autres logiciels qui consomment le flux

si je devais donner une fréquence, je dirais que c’est 1/3 des snapshots qui sont dans cet état, avec plus ou moins de hauteur de dysfonctionnement

bonne journée

J’ai aussi des flux sur 1 minute et je les consulte régulièrement, je n’ai jamais eu ce bug d’image.
Peut être qu’en fonction du format du flux (compression / résolution / bitrate) cela peut faire ça ?

@bong101 Ok, donc configuration assez basique.

Je veux bien que tu créé une issue Github pour qu’on garde une trace du problème.

Et niveau machine, tu es sur quel genre de hardware ? C’est quoi le modèle exact de la caméra ?

De mon côté le flux est sur 2 secondes, et je n’ai eu le problème que cette fois.

@bong101 Je serais intéressé d’avoir ton test du live de la fonctionnalité « live streaming de caméra » avec cette caméra pour voir comment ça tourne ( Streaming de caméra live dans Gladys Assistant 4.23 | Gladys Assistant ) :slight_smile:

Bonjour Pierre-Gilles

Tout d’abord, Gladys est hébergée par une Raspberry Pi3. ( et il n’y a que ça sur cet hôte)
Je vais donc le mettre au placard, dès que je peux commander un Pi4. Je scrute https://rpilocator.com/ régulierement
Ensuite, j’ai toujours le figeage de la capture d’image.
Et lors dun live, j’ai le « sablier » qui apparaît assez vite, genre 10 sec. Entre le Pi et la camera, un reseau CPL

Camera TP link Tapo C310

A bientôt

Ok, as tu envisagé un mini PC ? On en parle pas mal sur le forum, c’est au final largement plus puissant qu’un raspberry pi 4 !

Je ne garantie pas que ça améliore le figeage de l’image (qui est peut être du a ta caméra), en revanche pour le live c’est clair que ça va améliorer les performances

Oui, j’y ai pensé, vu que l on en parle pas mal ici…
J’ai un petit rack de raspberry et ce serait un matériel en plus.

ensuite le prix…« abordable » on se retrouve avec un Celeron 2 coeurs…je crois que je préfère un matos avec plus cœurs…et c’est donc plus cher

1 Like