Comptabilité ampoule yeelight

Possibilité de contrôler les ampoules yeelight (couleur/blanc)

je suis prêt à reprendre la suite de [v4] Dev service Yeelight si il manque quelque chose pour ce service

3 Likes

Il y a déjà une PR qui est plutôt en phase final :

J’attend la réponse de NickDub à mon dernier message, @Exilon62 je t’invite à t’abonner aux notification de la PR, si jamais tu vois que ça ne avance plus tu peux t’organiser avec lui pour aider ?

1 Like

@Pti_Nico Je mets un message ici en plus du message que je t’ai mis sur GitHub.

Peux-être qu’il faudrait qu’on se fasse un appel pour regarder ces problèmes de Discovery, ça serait peut-être plus simple ?

Tout à fait, car de mon côté, je n’ai pas le problème.

Tu seras là à l’appel développeur de ce soir ? On peut en parler ce soir !

Hello,

Je viens ici pour faire un retour sur le service.

De mon côté pas de soucis, j’ai réglé le soucis que @pierre-gilles a eu (effectivement si on bourine la page il y a une erreur, un peu tiré par les cheveux comme approche car ça arrivera jamais mais c’est « corrigé » je pense.

J’ai rajouté un model en plus :slight_smile:

Je redis quand j’ai poussé l’image sur celui de @Pti_Nico .

Pull request qui corrige le soucis et rajoute mon device ! :slight_smile:

1 Like

Salut @damalgos,

Je t’ai mis quelques commentaires à propos de ta PR.
Sinon, bien vu pour l’ajout du model :wink:

Oh oui idiot ce que j’ai fais :smiley:

Par contre pourquoi tu veux que je rebase ?

On peut pas partir de ce principe là, tout ce qui « n’arrivera jamais » arrivera chez l’utilisateur final, on le sait, c’est comme ça en développement informatique.

Et là pour le coup, c’était un bug vraiment critique (un crash), donc clairement un truc qui ne doit jamais arriver à l’utilisateur final, sinon son retour sur Gladys ça sera « ça crash, mauvaise stabilité du logiciel ».

Je sais bien après je voyais pas trop comment un utilisateur peut arriver dans ce cas la :smiley: J’ai du bouriner et ouvrir 20 fois la page en faisant plein de clique droit ^^ Je disais juste ça comme ca ahah C’est un bug critique mais qui a très peu de chance d’arriver. Effectivement il est important de le corriger.

Il y avait des conflits, car ta branche n’est pas à jour.

@damalgos, j’ai fait quelques dernières modifs, concernant la création des devices (gestion par features et non par model).
Dis moi si tout est OK pour toi…

Hello,

Du coup j’ai fais mes tests, pour moi aucun problème. A savoir que mon ampoule est une ampoule qui gère les couleurs. Il me semblait qu’on gérait ça dans gladys non ?

Et je peux que gérer on off, il voit la feature luminosity mais pas présente dans le dashboard.

Merci :slight_smile:

J’ai implémenté la gestion de la couleur et de la température, mais il semble que ça ne soit pas fonctionnel à partir du dashboard, comme pour la luminosité, dans Gladys…

La couleur est fonctionnelle sur le Dashboard :slight_smile: il faut que ton service gère la couleur de la même manière que Gladys par contre (regarde le service Philips Hue par exemple)

Je faisait référence à la température…
La couleur fonctionne bien, en effet :wink:

1 Like

Pour info, j’ai testé la PR ce matin, et j’ai toujours le même problème ça fait un peu n’importe quoi le discover:

Je fais rien de fou, je me balade juste dans l’UI. Est-ce que vous arrivez à reproduire ce genre d’erreur ?

Effectivement de mon côté même problème, après c’est peut être aussi parce que je passe par WSL2 pour tester…
Je ne sais pas trop comment fonctionne WSL2, est ce du à une isolation du réseau, et donc que la recherche s’effectue sur le réseau locale (de WSL2) et pas du réseau WIFI / WAN ?