Scène d'une Lampe virtuel qui commande 4 lampes pour la luminosité

J’ai créer une lampe virtuel MQTT :

cela fonctionne bien pour commander l’allumage avec cette scène :

(il y a une autre scène équivalente pour l’extinction)

J’ai essayé de faire la même chose pour la luminausité avec cette scène :


Mais cela ne fonctionne pas… (le déclanchement n’a pas lieu quand je change la valeur de luminosité de la lampe virtuel sur le dashboard)

supprime « récuperer le dernier etat »

Si je supprime « résuperer le dernier état » je ne peut pas récupérer de variable non ?

image

de tout façon j’ai mi « envoyer un message » dans la première action et il n’est pas envoyé donc le déclencheur n’est même pas activé… (sauf si je fait « démarrer » en haut de la scène)

dans le premier au niveau déclencheur t’as pris en changement d’état on/off prend le seuil directement

Excuse moi, mais pourrai tu faire un exemple, je ne vois pas comment récupérer le seuil de luminosité pour le réinjecter en variable…

image

Ah mais je voudrais changer la luminosité sur l’action et pas allumer la lumière. :confused:

c’est pas ta 1ère capture ! tu veux faire quoi exactement ?

Je veux récupérer la luminosité de la lampe virtuel et la passé au 4 lampes réels.

C’est exactement ce que j’ai fait, mais cela ne fonctionne pas… La scène n’est même pas déclenché quand je change l’état de la luminosité de la virtuel…

si tu cliques sur démarrer la scène ca marches au moins ?

Comment changes-tu la valeur de luminosité du device virtuel qui te sert de déclencheur ?
Si je comprends bien, tu veux que quand la valeur de luminosité change sur ton device virtuel, ça se propage aux lampes réelles, c’est bien ça ?

Je change la valeur sur le Dashboard :
image
Cela fonctionne pour le On/Off mais pas pour la luminosité (ni la température).

Si je comprends bien, tu veux que quand la valeur de luminosité change sur ton device virtuel, ça se propage aux lampes réelles, c’est bien ça ?

oui c’est bien cela !

Quand je click sur démarrer la première action de récupéré l’état est bien faite (vérifier avec envoie d’un message) et sur la deuxième action la variable réinjecté dans un message est vide…

Donc, la variable est bien récupérée mais mal réinjectée ?
Tu es dans l’onglet ‹ calculée ›. Si tu ajoutes un +1? Ou si tu la mets dans ‹ simple ›?
C’est quel type de valeur? Numérique simple ?
Tu sais bien contrôler tes lampes indépendamment via le dashboard ?

Cela fonctionne avec la version 4.36 de Gladys ! Merci :wink:

1 Like