THR320 Sonoff Tasmota - résolution problèmes

Bonjour
C’est mon premier vrai post sur ce forum donc soyez cléments !!

J’ai installé il y a quelques mois Gladys sur un PI4 8Go sous Docker avec les mises à jour suivi par Watchtower
Je suis également mes containers avec Portainer
Je suis mon PI4 notamment avec webmin

J’ai décidé d’aller plus loin dans le sujet domotique en commençant par surveiller des températures et des relais…
Je viens de faire l’acquisition d’un Sonoff TH Origin 20A (THR320) + capteur température
j’ai horreur de devoir passer chez le voisin pour aller de ma cuisine au garage donc passer par les serveurs ewelink NON !! NIET !!

Aussi étape 1 : flashage Sonoff vers tasmota avec Esptool et tasmota web :
identification esp
backup
erase
flash
config tasmota

A cette heure j’ai bien le tasmota qui remonte dans Gladys après avoir activé le MQTT qui a créé un nouveau bébé sous docker…

Par contre et c’est là ou je bloques le THR320 est reconnu comme relai mais pas la température (Grrrr)

Ne connaissant pas les outils Gladys, MQTT et autres tasmota je penses qu’il faut aller voir dans des logs, peut être confirmer la config tasmota du THR320…

quelqu’un peut il m’expliquer comment appréhender ce problème ?

Merci

Bonjour

Je fais partie des collaborateurs Tasmota et je découvre Gladys Assistant
J’ai bien vu dans la doc que Gladys supportait la découverte (discovery) des équipements Tasmota mais cela semble ancien et il y a eu du changement chez Tasmota concernant la publication des messages MQTT de discovery.

Historiquement, Tasmota utilisait le standard « Home Assistant » et publiait ses messages de Discovery sur le topic homeassistant/..... Ce mode s’activait notamment par l’utilisation de la commande de configuration Setoption19 1.
Mais en parrallèle l’équipe Tasmota a développé son propre standard de discovery qui utilise le topic tasmota/... afin d’offri aux logiciels de domotique une solution indépendant de « home assistant ».

Le temps passant, l’équipe de développeur de Tasmota n’a plus personne pour maintenir le code associé au standard « homeassistant » et il a été décidé de désactiver ce code dans les nouvelles releases à partir de la 11.x
De leur coté, les développeurs de Tasmota on embrayé la migration en créant un plugin hatasmotapour home assistant.

En conclusion, si l’intégration de Tasmota dans Gladys dépend du standard homeassistant, il faut considérer ce mécanisme comme obsolète.

Je suis à votre disposition si vous avez besoin de plus de détails

Cordialement

Bonjour
De mon coté j’ai testé avec et sans l’option SetOption19 et avec reboot entre chaque essai…
Rien ne change le capteur de température n’est pas vu…

J’ai telechargé le client MQTT Explorer
On retrouve bien :

{« sn »:{« Time »:« 2022-08-24T17:59:31 »,« DS18B20 »:{« Id »:« 3C6404577D30 »,« Temperature »:23.4},« ESP32 »:{« Temperature »:46.7},« TempUnit »:« C »},« ver »:1}

Ce qui me fait dire que le capteur remonte bien dans le broker MQTT

Merci de votre aide

Est-ce que tu as changé la config FullTopic ?
Sur quel topic est-ce que tu vois passer le message ci-dessus
Alternativement copie ici un extrait du log de la console Tasmota notamment avec les messages STATE et SENSOR

Sur MQTT Explorer :

Sous tasmota/discovery/782184BC276C

{« sn »:{« Time »:« 2022-08-24T17:59:31 »,« DS18B20 »:{« Id »:« 3C6404577D30 »,« Temperature »:23.4},« ESP32 »:{« Temperature »:46.7},« TempUnit »:« C »},« ver »:1}

Sous tele/tasmota_BC276C/SENSOR

{« Time »:« 2022-08-24T19:09:29 »,« DS18B20 »:{« Id »:« 3C6404577D30 »,« Temperature »:23.5},« ESP32 »:{« Temperature »:46.1},« TempUnit »:« C »}

Est ce que tu peux taper la commande status 8 dans la console et dire si la température apparaît dans Gladys ?


Je pense que j’ai trouvé
Il semble que Gladys ne supporte que les DHT11 et AM2301, pas les DS18x20
Et il se peut que Gladys en plus ne cherche pas de la bonne façon

Voir Gladys do not parse Tasmota SENSOR message correctly · Issue #1590 · GladysAssistant/Gladys · GitHub

Il faut que tu donnes plus de détails sur ta configuration

La commande status 8 dans la console Tasmota donne le message suivant (dans la console) :

20:25:46.714 MQT: stat/tasmota_BC276C/STATUS8 = {« StatusSNS »:{« Time »:« 2022-08-24T20:25:46 »,« DS18B20 »:{« Id »:« 3C6404577D30 »,« Temperature »:23.6},« ESP32 »:{« Temperature »:46.1},« TempUnit »:« C »}}

Je retrouves aussi ce message dans STAT/STATUS8 sous MQTT Explorer

Mais je n’ai rien dans Gladys en reactualisant la decouverte des périphériques Tasmota

J’ai fait une rapide comparaison - test croisé avec home assistant :
Pour le fun j’ai ajouté deux sondes de température DS18x20

J’espère que Gladys va être upgradé

On jettera un œil au retour de vacance :relaxed:

Merci pour le debug @tiboys et @Barbudor

Je prends le merci pour moi ??? Lol

J’aime bien tester des trucs d’ailleurs si cela permet de faire évoluer Gladys,
C’est presque plus intéressant que quant cela fonctionne du premier coup…on s’ennuie vite (lol)

il faut pas aider à me chahuter et me solliciter

Bonjour,

Gladys ne dépend pas du standard homeassistant :slight_smile:

Nous souhaitons éviter de devoir modifier la configuration par défaut du firmware (sauf pour du debug). En revanche, s’il est conseillé d’appliquer certaines options, nous le proposerons via Gladys.

En effet, l’intégration des devices se fait au cours de l’eau, n’ayant pas le matériel pour tester, et ne surveillant pas les nouvelles intégrations dans Tasmota au fil de l’eau, nous attendons que la communauté le demande.

J’ai regardé le ticket sur Github, le hack est d’ajouter le préfixe StatusSNS comme clé sur le dernier argument de la méthode.

Merci à @Barbudor de participer aux discussions autour de Tasmota, nous sommes preneur des bonnes pratiques à appliquer que nous aurions mal interprétées.

Merci @Titou43 pour tes retours, nous allons intégrer ton device ASAP. Nous avons la même demande pour le BL09XX.

Bonjour @AlexTrovato
Merci pour ton feedback

Concernant la limitation sur les capteurs DHT11/AM2301 (les pire possibles sur le marché😁) pourquoi ne pas juste ignorer la clé du nom-du-chip ? Actuellement vous filtrer mais vous n’utilisez pas la valeur de la clé nom-du-chip. Pourquoi ne pas passer directement à \\..+\. ?
La majorité des utilisateurs de Tasmota utilisent le DS18x20 pour la temperature (j’ai vu jusqu’à 20 DS18x20 sur un Tasmota) ou les BME280/HDC1080 pour temperature+humidité.
Quand on utilise + que un DS18x20 par exemple, les clés sont "DS18B20-1":{...}, "DS18B20-2":{...}
Voir même (via une option) DS18B20-XXXX utilisant les 4 derniers chiffres du numéro de série du chip (« id ») afin de régler les problèmes d’ordre aléatoire au redémarrage.

Les BL09XX sont des capteurs de consommation électrique dont l’intégration dans Tasmota est au niveau de la clé ENERGY. Le type de composant utilisé est complètement invisible pour l’utilisateur.
Donc pas sur de comprendre ce qui vous manquerait à ce niveau.

A disposition si vous avez des questions sur Tasmota
A+

Bonjour
Je viens un peu aux nouvelles, si je peux aider à faire des tests…

Merci de vos aides

Bonjour
Petit up vers les développeurs , vous avez pu trouver un peu de temps pour ce sujet ?

Merci !!

Pour info il y a une PR en cours ( Add more temp devices by atrovato · Pull Request #1570 · GladysAssistant/Gladys · GitHub )

@AlexTrovato Il y a une image Docker de test ?

Je viens d’en générer une à jour atrovato/gladys:tasmota.
Amusez vous bien :slight_smile:

1 Like

Bonsoir
Il faut m’en dire un peu plus…désolé pour moi qui suis nouveau !!
Que dois je faire pour tester ?

Merci

Salut @Titou43 !

J’avais fais un post à l’époque qui explique comment lancer une image de test:

Par contre je te préviens, on est en mode « développement » là, c’est pas un process facile pour un novice complet et c’est à faire dans un environnement séparé de ta production !

Le but ici est de tester que le développement répond au problème avant de déployer ça en production. La mise à jour en production elle se fera automatiquement sans aucune action requise :slight_smile:

Bonjour…

Et ARG je n’arrive à lancer le serveur MQTT depuis l’image atrovato/gladys:tasmota

Si je coches MQTT dans un container Docker cela ne veut pas
Si je vais chercher sur le MQTT de mon Gladys fonctionnel il ne s’y connecte pas non plus

Dans les logs de docker j’ai cela :

2022-09-14T18:56:44+0200 service.start.js:44 (Service.start) Unable to start service mqtt PlatformNotCompatible [Error]: DOCKER_CGROUP_CONTAINER_ID_NOT_AVAILABLE

Pour la config :
je suis sur un PI 4 8Go avec Debian 11 en 64Giga

Va falloir nous en dire plus sur ce que tu as fait pour en arriver là ( on avait prévenu :neutral_face:)