Tuile camera est freeze au premier affichage du dashboard

Bonjour tout le monde !

Je rencontre un soucis lorsque j’accède au dashboard.
En effet j’ai configuré une caméra (Xiaomi Mi home 1080p) avec un rafraichissement toutes les 2 secondes.

Lorsque j’affiche pour la première fois le dashboard l’image est figée. Je dois actualiser ma page pour que l’image se réactualise toutes les 2 secondes.

Est-ce que je peux / dois faire quelques tests pour résoudre ce problème ?

Hello!

C’est un bug de la partie websockets du frontend, le bug apparait aussi sur le chat !

On a référencé le bug ici, il est assez simple à reproduire:

En ce moment je suis assez occupé sur l’intégration Google Home donc je pourrais pas m’en occuper tout de suite, mais je suis preneur de toute contribution si quelqu’un veut s’en charger :slight_smile:

1 Like

Salut @guim31

Peux tu me dire comment tu as fait pour connecter ta cam xiaomi? Quelle est l’adresse pour le flux ?

Merci :wink:

Salut @jerome

J’ai voulu dans un premier temps flasher ma caméra avec un firmware modifié trouvé ici : GitHub - TheCrypt0/yi-hack-v4: New Custom Firmware for Xiaomi Cameras based on Hi3518e Chipset. It features RTSP, SSH, FTP and more!

Mais évidemment mon modèle n’était pas compatible (Need help! Yi home 1080p 6FUS can't upgrade firmware · Issue #297 · TheCrypt0/yi-hack-v4 · GitHub)

Quelqu’un a alors posté ce lien :

Et tout a fonctionné ! Je te laisse regarder, n’hésite pas à me demander si tu es en galère

Hello @guim31, le bug que tu as remonté est fixé, il partira dans la prochaine release!

1 Like

Magnifique !! Merci Pierre-Gilles :slight_smile: