Gladys sur PI4 avec Docker

Bonjour
Je voudrais tester Gladys

Pour ce faire j’ai un raspberry PI4 sur lequel j’ai docker qui tourne avec Portainer

Question 1 :
En suivant l’installation de base j’ai eu un message d’erreur de Docker :

Error response from daemon: unknown log opt ‘max-size’ for journald log driver

C’est lié au paramètre *–log-opt max-size=10m *

J’ai donc fait l’installation sans ce paramètre, mais quelqu’un a t’il eu ce bug ??

Question 2 :
Faut il impérativement mettre la ligne suivante :
–privileged
J’ai lu dans une prescription de l’ANSSI que il fallait éviter de donner trop de droit au container par cette option…

Question 3 :
J’ai un container (AdguardHome) qui utilise le port 80 et du coup le container Gladys refuse de démarrer…raison (dans les logs…) port utilisé…
J’ai stoppé un temps AdguardHome et Gladys est accessible mais peut on changer le port 80 de Gladys ???

Enfin j’en termines par :
un grand bravo pour cette application
un grand merci pour vos lumières à tous

Hello,

Question 1:
Si tu passes par portainer 'est possible que cette option soit géré par portainer ? D’autres peuvent surement mieux répondre à cette question comme ca pas la réponse :slight_smile:

Question 2:
L’ANSSI pose des conditions pour des cas particuliers. Par exemple un serveur web avec un site internet classique ne devrait pas avoir le droit d’accéder à tout et n’importe quoi donc pas de priviliged.
Mais pour de la domotique c’est nécessaire, il faut que ton docker accède aux autres docker, que tu accèdes à la machine / lire l’usb etc. C’est nécessaire
Par contre c’est vrai que c’est une bonne pratique de ne pas le faire si tu en as pas besoin :slight_smile:

Question 3:
Oui tu peux :slight_smile:
Gladys expose son port 80, mais la machine peut très bien bind un port donc par exemple:
-p 8080:80. Ici tu associes le port 8080 de ton raspberry au port 80 du docker :slight_smile:

1 Like

Attention pas ici, car on lance Gladys en mode “network=host”, ainsi il faut juste changer le port dans le container en changeant la variable:

 -e SERVER_PORT=80 \

Tu peux mettre n’importe quel port à la place :slight_smile:

2 Likes

@damalgos
@pierre-gilles

Bonjour à vous deux

J’ai effectivement testé ce midi avec :
-p 8080:80 et j’ai la même erreur

Je ferais ce soir le changement comme préconisé par Pierre-Gilles
Je mettrais par exemple
-e SERVER_PORT=90 \

Je vous fait un retour trés bientôt

Alors attention avec les ports :slight_smile:

Il y a deux types de port sur linux, les ports qui sont dit “réservé”, et les ports libres.
Les ports réservés (80 http, 443 https, 22 ssh, …).

Le mieux étant de prendre un port qui n’est pas réservé par le système.
En gros de 1023 à 65535.

Bonsoir
J’ai pris le port 1030 et j’ai accès à Gladys Assistant

Merci de vos premiers retours sur ce point.

Faut que je recherche l’option “log opt max size” maintenant

1 Like

Salut @Titou43, et si tu peux à la fin faire un mini-tuto de comment tu as fait pour installer gladys via portainer ! :wink:

@cce66

Bonjour, Portainer n’est pour moi qu’une interface de gestion des containers, je mets en place mes containers par SSH ou par le terminal comme indiqué ici :

Tu as tout dans le paragraphe :

## Lancer un container Gladys Assistant

Pour lancer Gladys, exécutez la commande suivante :

J’ai juste modifier :

  • Le port : -e SERVER_PORT=80 \ (1030 à la place de 80)

  • j’ai supprimé dans un premier temps :

*–log-opt max-size=10m * car cela me mets un message d’erreur sur le Raspberry pi4
*–privileged * pour mes premiers tests

Et bien sur j’ai changé le dossier de destination

Voilà

J’aimerais bien cependant trouver cette p… d’erreur de --log-opt max-size=10m \

Est-ce que tu peux regarder le log-driver par défaut en lançant la commande docker info --format '{{.LoggingDriver}}' ?
Selon le driver, l’option log-opt max-size n’est pas disponible.

Tu peux forcer le driver en ajoutant l’option --log-driver json-file quand tu lances ton container.

Bonsoir

A la commande : docker info --format '{{.LoggingDriver}}'

J’ai la réponse : journald

ça vaudrait peut-être le coup de rajouter ça à la commande sur le site non ?

Bonsoir
Du coup il faut ajouter au fichier d’installation ces deux lignes ??? :
–log-driver json-file
–log-opt max-size=10m \

Yes ! Comme ça:

–log-driver json-file \
–log-opt max-size=10m \

Tu peux changer “10m” si tu trouve que c’est pas assez (ça fait 10mo de log au max)

Bonsoir
je viens de tester …
C’est passé sur Raspberry Pi 4

2 Likes