[RESOLU] Connexion wifi sur raspbian buster impossible

Bonjour,
Je cherche depuis quelques heures maintenant à configurer mon Raspberry 3B+ avec Gladys V4 avec une connexion WIFI plutôt qu’avec Ethernet.

J’ai essayé la méthode simple et classique : raspberry-lab .fr /Debuter-sur-Raspberry-Francais/Connecter-le-Raspberry-Pi-au-Wifi/

Et j’ai essayé l’ancienne méthode avec Interfaces : www.windtopik.fr/configurer-wifi-raspberry-pi/

Sur ce post ils ont l’air de dire que ce n’'est pas possible : WIfi sur Gladys V4

Est-ce un problème de HypriotOS ou de Docker tout simplement ? J’ai cherché aussi de ce côté là, mais je n’ai pas trouvé sur la machine les fichiers auquel ils faisaient référence … Comme ils disent ici : community.brewpi .com /t/setting-up-wifi-in-hypriot-solved/2686/4

Bref, je suis un peu perdu :frowning:
Un coup de main ne serait pas de refus svp !

P.S.: Désolé pour les liens cassés mais pour les nouveaux 2 liens par message

Hello @Mijsoot !

Alors on utilise plus HypriotOS donc ne part pas de ces messages.

Le tutoriel que tu as mis en lien est très vieux (2015), et depuis ça a changé. Il faut chercher pour Raspbian Buster (la dernière version de Raspbian qu’on utilise dans Gladys)

J’ai trouvé ce tutoriel qui a l’air a jour:

Est-ce que tu peux tester et nous dire ?

Et un autre de ma part : https://www.fotozik.fr/raspberry-pi-headless-en-wifi

Bonjour les gars,
Merci pour vos réponses, mais je pense que vous avez été trop rapide …
J’ai précisé dans mon message que je ne pouvais mettre que 2 liens alors j’ai cassé les liens pour pouvoir les mettre dans mon texte et le premier été celui-ci :
Connecter son Raspberry Pi au réseau Wifi
Et je précise bien que c’est effectivement la méthode simple et classique et effectivement à jour.

En plus, j’ai la chance d’avoir 2 Box chez moi et donc 2 réseaux WIFI, j’ai donc pu essayer les 2 et j’ai le même résultat.
En fait je ne sais pas trop quel Log regarder pour trouver le problème.

@pierre-gilles merci pour l’info sur HypriotOS ce qui explique pourquoi je n’ai trouvé aucun fichier !

@cicoub13 j’ai lu le tuto et c’est aussi exactement le même que j’ai suivi eu dessus.

En fait est-ce que vous même vous arrivez à vous connecter en WIFI ???

Merci d’avance en tout cas !

Bon j’ai fini par trouver …
Je ne comprends pas parce que justement sur les dernières version de Debian c’est censé être automatique, mais il fallait préciser le type de clef WIFI avec

key_mgmt=WPA-PSK

Dans le fichier /etc/wpa_supplicant/wpa_supplicant.conf, ce qui nous donne

country=fr
update_config=1
ctrl_interface=/var/run/wpa_supplicant

network={
   scan_ssid=1
   ssid="Votre_SSID"
   psk="Votre_pass"
   key_mgmt=WPA-PSK
}

Merci en tout cas ! Et cela pourra peut-être servir à d’autres

2 Likes