Gladys en carafe

Bonjour à tous,

Depuis quelques jours mon instance Gladys est en carafe :disappointed_relieved::grimacing:

Gladys inaccessible depuis le navigateur mais aussi depuis le SSH (via Putty).

Par contre le ping repond correctement !

Ayant réinstallé il y a plusieurs semaines sur un SDD plus plus de pérennité, j’ai initialement pensé à un problème d’alimentation électrique (juttilise le pont zigbee usb de Sonoff).

J’ai donc opté pour une alimentation séparée pour le SSD… mais sans succès.

A chaque reboot (mode barbare obligatoire : débrancher/rebrancher), j’ai un accès sur le navigateur mais cela ne dure que 2 ou 3 minutes !

Est-ce que quelqu’un a des idées ?

Bonjour,

Une réponse au ping, c’est juste l’interface IP qui est toujours « vivante »

  • Y a t il (il devrait y avoir) des infos dans :
    /var/log/syslog
    /var/log/messages
    /var/log/kern.log

  • Quel est le modèle de raspberry ? combien de mémoire ? quel OS ?

Phil

merci @Phil pour ton retour

Malheureusement après redémarrage je n’ai pas le temps de faire grand chose… ça plante trop rapidement.

C’est un RPi 3B+ 1GB, pour l’OS il s’agit de l’image Gladys officielle.

ok.
les fichiers en question syslog message et kern.log , le nom « tout court » = fichier courant, les anciens fichiers sont suffixés avec .1 , .2 etc , ensuite avec .gz (les fichiers sont compressés pour prendre moins de place)
ex sur un rapsberry pi qui tourne depuis des mois, sans arrêt.

root@piwigo:/var/log# ls -larlt syslog*
-rw-r----- 1 root adm 734411 Jan  9  2022 syslog.2
-rw-r----- 1 root adm 528729 Jan 23  2022 syslog.4
-rw-r----- 1 root adm 475204 Jan 30  2022 syslog.3
-rw-r----- 1 root adm 112998 Dec 11 00:00 syslog.4.gz
-rw-r----- 1 root adm 111543 Dec 18 00:00 syslog.3.gz
-rw-r----- 1 root adm 114919 Dec 25 00:00 syslog.2.gz
-rw-r----- 1 root adm 890876 Jan  1 00:00 syslog.1
-rw-r----- 1 root adm 771513 Jan  5 09:09 syslog
root@piwigo:/var/log# ls -larlt messages*
-rw-r----- 1 root adm 142 Dec  4 00:10 messages.4.gz
-rw-r----- 1 root adm 141 Dec 11 00:10 messages.3.gz
-rw-r----- 1 root adm 250 Dec 18 06:19 messages.2.gz
-rw-r----- 1 root adm 148 Dec 25 00:10 messages.1
-rw-r----- 1 root adm 148 Jan  1 00:10 messages
root@piwigo:/var/log# ls -larlt kern.log*
-rw-r----- 1 root adm  8944 Nov  3 10:03 kern.log.4.gz
-rw-r----- 1 root adm 15127 Nov 10 23:18 kern.log.3.gz
-rw-r----- 1 root adm 24649 Nov 11 16:38 kern.log.2.gz
-rw-r----- 1 root adm   145 Nov 14 19:58 kern.log.1
-rw-r----- 1 root adm     0 Nov 20 00:00 kern.log

Si c’est la clé sonoff qui fait planter, il serait utile de démarrer le raspberry pi sans la clé, pour accéder à ses fichiers .

pi3 1Go
gladys utilise docker etc , 1Go c’est peut être court non ?
y a t il des abaques ou des recommandations pour gladys du style : (peut être une question pour @pierre-gilles ?)

  • configuration minimun : pi3 - xGo
  • avec x devices / scènes : mémoire recommandé yGo
    etc
    d’expérience la mémoire y en a jamais assez, le cpu c’est « juste » que c’est plus lent ou plus rapide
    Le résultat de la commande free serait intéressant (Display amount of free and used memory in the system)

Un système unix qui plante y a forcément une raison.
Je veux bien lire les fichiers
Phil

OK merci

Je le relance ce soir sans la clef Zigbee pour te faire un retour

ok
c’est un raspberry pi3 : donc l’image qui tourne c’est bien une 32-bit ?
cf la discussion dans le fil (Live Youtube bilan de 2022 et projets pour 2023 ce mardi soir à 21h! - #35 par Phil) …

Phil

De mémoire je dirais plus 64

hum, je pense qu’une version 32-bit serait celle qu’il faut
cf : https://raspberrytips.fr/raspberry-pi-os-versions/
y a un résumé en bas de page que je recopie ici :

Donc, pour résumer vos options :

* **Les débutants et la plupart des gens**⇒ Raspberry Pi OS Bullseye (32-bit).
* **Pas d’Internet sur le Pi** ⇒ Raspberry Pi OS Bullseye Full (32-bit).
* **Utilisateurs avancés sans écran** ⇒ Raspberry Pi OS Bullseye Lite (32-bit).
* **Utilisateurs aventureux avec un modèle récent** ⇒ Idem mais en 64-bit.
* **Utilisateurs prudents** ⇒ Legacy.

Perso j’ai plusieurs pi qui ronronnent sans aucun problème … version 64-bit uniquement sur des pi4
Phil

Suis rentré un peu tard pour les tests… je compte sur le week-end pour regarder à ça…
Et remettre Gladys sur pied.

Provisoirement avec mon Pi et une version 32 et par la suite voir avec un miniPC

1 Like

J’ai donc remis l’image en 32b

Plusieurs problème rencontrés :

  1. impossible de restaurer depuis la page d’accueil - problème à l’identification

  2. j’ai donc créé un utilisateur local puis restauré la sauvegarde dans Paramètres

  3. La restauration s’est faite, le dongle USB Z2M est configuré, le service Z2M tourne sans problème (coche verte OK)…

  4. Mais aucun dialogue avec les devices zigbee…

Dèg !

Par contre le service BroadLInk fonctionne parfaitement

Ça c’est normal tu dois ré-appairer tes devices, le backup ne prend pas en compte zigbee2mqtt

Le sujet est en cours le dev est quasi fini

Ca c’est top !

C’est ce que j’ai commencé à faire hier soir… je me suis douté en voyant le panneau « decouverte Zigbee » complètement vide !

Par contre le panneau « Appareils » listait toujours tous mes devices…

l’appairage est donc simplifié car un simple reset et tout le monde rentre dans sa case !!!

Oui il faut juste les ré-appairer côté gladys ils existent déjà

Vendredi soir (6/01/23) j’ai voulu accéder à l’interface de Gladys par l’adresse IP mais impossible. J’ai essayé sur mon PC et mon smartphone avec Firefox et Chrome et avec Putty. Toujours la même chose : La connexion a échoué.

Pareil samedi, dimanche et aujourd’hui.
EDIT 3 (14/01/23): Cela fait plus d’une semaine que je n’ai pas accès à l’interface de Gladys, sauf en passant par Gladys Plus… Je m’absente une semaine à partir de demain. Si quelqu’un veut essayer de m’aider, c’est soit aujourd’hui, soit à partir de samedi prochain.

Par contre c’est accessible via Gladysplus
EDIT : et le ping répond.

Je suis passé la semaine dernière sur mini-PC.

EDIT 2 (9/01/23): Côté mini-PC, Ubuntu fonctionne, l’accès à Gladys en 192.168… fonctionne, le ping vers le PC Windows fonctionne.

Les logs :
Mince, j’ai fait un pdf de 35 pages avec docker ps et les logs des conteneurs. Il n’est pas possible de le déposer.
Comment le mettre ? Un lien vers ma Dropbox ?

EDIT 4 (14/01/23) : docker restart gladys (en terminal sur le mini pc) ne change rien

EDIT 5 (23/01/23) : je suis de retour si quelqu’un peut m’aider.
On dirait que les connexions vers le mini pc sous Linux sont bloquées.

Comme cela c’est difficile de deviner ce qu’il se passe mais ça doit être un problème, je pense, de réseau chez toi sinon Gladys Plus ne fonctionnerais pas et l’accès à Gladys depuis ton mini pc non plus.

Es-tu sur le même réseau local? Je me rappel un de tes post ou tu indiquait avoir plusieurs réseaux local.

Oui, Gladys est sur une adresse en 192.168.68.1…
mon PC : 192.168.68.1…
mon smartphone : 192.168.68.1…
Passerelle : 192.168.68.1
Le masque est le même pour tous.
Après avoir installé Gladys sur le mini-pc, ça fonctionnait, et un jour, plus.

EDIT 1 : Une question :
Gladys et le mini-pc peuvent-il, doivent-il, avoir la même adresse IP fixe ?
et une autre :
Est-ce que cela peut venir de la config « Routes » IPv4 du réseau filaire du mini-PC ? (Elle est en Automatique)

L’adresse de Gladys est en automatique mais as tu ton routeur de configuré pour lui donner une adresse ip fixe?

Sinon as tu fais un ping depuis ton pc?

As tu fais un scan avec un outil comme Advanced ip scanner ou wireshark?

Depuis ton mini pc quel adresse tu entres pour accéder à gladys?

Oui, sur le mini-pc qui héberge Gladys c’est en automatique.
J’ai fixé l’IP sur le routeur.

Pour le ping,

Je viens de brancher le PC en ethernet (il était en wifi jusqu’à présent) mais rien ne change.
Résultat du ping :
Statistiques Ping pour 192.168.68.1…:
Paquets : envoyés = 4, reçus = 4, perdus = 0 (perte 0%),
Durée approximative des boucles en millisecondes :
Minimum = 2ms, Maximum = 5ms, Moyenne = 3ms

Sur le mini-pc, je mets soit l’ad IP fixée sur le routeur (192.168.68.1…), soit localhost.

EDIT 1 :
Résultat de Advanced ip scanner :

Deja si le ping répond c’est bien. Et ton navigateur il affiche quoi quand tu essaie d’accéder a gladys?
Peux tu mettre une capture d’écran ?

La page est très longue a chargée dans FF et j’obtiens :
Firefox :

Firefox page privée :

Chrome :

Aucun proxy.
Il était en « Utiliser la config du pc » . Je l’ai enlevé mais rien ne change.
Je vais redémarrer FF pour voir.
Pas mieux…