Retour Gladys V4.0.4 - Dev Color-Picker

Bonjour,

Tout d’abord, il est important de remercier @AlexTrovato pour son travail et pour cette PR attendue par tous les possesseurs d’ampoule colorée.

Petit retour sur l’utilisation :

1- Lorsqu’on arrive sur le Dashboard, la case au départ est grise et ne contient pas la couleur actuelle. Egalement, si l’on change la couleur, la case prend bien la couleur, mais dès que l’on fait un refresh la case reprend en gris. Problème déjà connu pendant les tests, une PR sera-t-elle prévue ?

2- A l’ouverture du color-picker que ce soit sur le dashboard du navigateur (Chrome) ou sur le téléphone, la fenêtre descend complètement vers le bas, cachant ainsi les cases de la pièce et des features du device. Est-il possible d’éviter ce phénomène de glissement automatique et de ne le faire que si nécessaire (feature en bas de page = remonter la fenêtre de la hauteur du color picker seulement).

Petit GIF pour visualiser les points 1 et 2

A part ça il est bien agréable de pouvoir piloter ça directement depuis Gladys. Vivement la Température et la Luminosité ^^

Spoiler ? ^^

image

Edit : Le GIF ne fonctionne a priori pas, désolé. J’ai fait plusieurs tentatives, le fiichier upload bien, le lien est ![Color-Picker|1x1](upload://ju27NM0m0AJA7nlX87iZWYIFmBK.gif) mais rien ne s’affiche dans l’aperçu. J’ai fait plusieurs tentatives avec des fichiers de 2 à 4MB mais rien de plus.

Edit-2 : C’est bon, merci @Jean34

1 Like

Héberge le sur casimage où autre ton gif

1 Like

Punaise le dashboard :sweat_smile:

Et encore, il n’y a pas encore tout le matos Netatmo … Ca va être illisible après ça !! Vivement le multi-Dashboard ^^ Après une solution à court terme pourrait-être juste un champ recherche !!

1 Like

Je n’ai pas eu ton problème numéro 1, j’ai essayé plusieurs fois mais tout fonctionne bien de mon côté.

Pour le problème 1, je pense que suivant l’intervalle de poll, la valeur réelle de l’ampoule n’a pas encore été récupéré quand tu vas sur le Dashboard (juste après avoir ajouté le device).
Tu peux essayer d’ajouter le device et d’attendre que le premier poll survienne pour vérifier ?

Aucun soucis là-dessus @cicoub13, les tests ont été fait quelques heures après l’ajout. De plus, une fois la couleur sélectionnée une première fois, elle passe dans la DB en “last_value” dans la table t_device_feature. Donc même si le poll n’avait pas encore eu lieu, au refresh de la page, elle aurait dû garder la couleur sélectionnée auparavant.

Tu as un comportement différent chez toi ?

Salut, merci pour les retours.
Ton device avec color picker est sur quel service d’intégration ?
Ce que dit @cicoub13 n’est pas forcément deconnant.

Salut,
Tous mes devices avec colorPicker sont sur Philips Hue.

@AlexTrovato je suis dans le même cas que @Terdious sur du Philips hue

De mon côté je testerai ça la semaine prochaine. J’ai une aeotec LED Bulb

Pour ce point, le poll Philips Hue n’agit que sur le binary on/off pour l’instant car il n’y avait pas la couleur jusque-là, c’est un manquement “normal”, il faut développer la feature :slight_smile:

Cf code:

Après, hors poll, il y a quand même un problème je pense !