Zigbee2mqtt: Instance Gladys se bloque après mise à jour d'un appareil

Chez moi c’est très peuplé …!!!

Je viens de cliquer sur ‹ Mettre à jour › sur mon appareil Prise Lisseur.

Je me retrouve avec une icone loading … et absolument rien de nouveau dans les logs Gladys.

Info :
Cela fait 3 min que j’ai cliqué, rien ne se passe, par contre l’utilisation du CPU de mon container est montée petit à petit :
image

Puis redescendu maintenant… pourtant mon spinner tourne toujours sur mon dashboard :

Je précise aussi que mon Gladys est inutilisable… plus rien ne se charge dans l’interface :confused:

EDIT :
La mémoire utilisée par le container aussi a grimpé d’environ 400m à 2Go après avoir cliqué

1 Like

Merci pour ton retour @guim31 !

Tu as des logs à nous montrer ? A mon avis, ce qu’il se passe c’est que Gladys essaie de cleaner des états sur le disque de la feature que tu as mise à jour…

Est-ce que par hasard tu as bougé les paramètres de conservations des données sur ces appareils :

?

PS: j’ai bougé dans un autre sujet pour pas perdre l’autre souci de @McFlyPartages qui n’est pas le même souci :slight_smile:

1 Like

Alors malheureusement je n’ai aucun logs… enfin si j’en ai mais il n’y a rien dedans.

Par contre, il est possible que j’ai modifié ces paramètres de conservation, mais c’était il y a genre 2 semaines (j’avais posté sur mon problème de disque dur plein) donc j’avais fait un peu le ménage là dedans.

Si je comprends bien, j’ai fait la modif, donc le device s’est ajouté à ma liste et lorsque j’appuie sur ‹ Mettre à jour › il nettoie les anciens états ?

Parce que je veux bien qu’il y en ai beaucoup mais quand même là j’ai redémarré mon container car ça a mouliné 13min … :confused:

Tu peux vérifier dans l’onglet « Tâche en arrière plan » si il y a eu des tâches de nettoyage, ça apparait dans cet onglet :slight_smile:

Non, je pense qu’il peut y avoir un bug qui justement remet l’état à l’ancien, tu veux vérifier si depuis la mise à jour ça a gardé ton setting ou ça l’a écrasé ?

J’aimerai y aller mais quand ça tourne l’interface plante

Je n´avais pas vérifié juste avant, mais je suis quasiment certain que j; avais décoché plusieurs paramètres il y a 15jours

Pas certain que ça aide :

Ok, ça confirme mes doutes !

J’ai créé une issue Github :

Non ce n’est pas ce type de job.

1 Like

Cool ! Merci @pierre-gilles

Bug fixé dans cette PR :

ça partira dans la prochaine version de Gladys :slight_smile:

1 Like

Trop réactif !! :grin: