Zigbee2mqtt ne connecte pas [Résolu]

Bonjour,
J’ai un RPI3 B
Gladys V4.28.0
J’ai vu que d’autres ont eu un problème similaire mais je n’ai pas trouvé la solution

La clé Zigbee est une Son Off V3, elle fonctionne bien sous Jeedom et Home assistant.

En fait j’ai 3 possiblités en usb
/dev/ttyACM0
/dev/ttyAMA0
/dev/ttyACM0-ITEAD-1a86

J’ai essayé avec les 2 premières, ça ne fonctionne pas
La 3ème est en bleu foncé et si je clique dessus j’ai de nouveau /dev/ttyACM0

L’installation est neuve.
J’ai réessayé 2 fois.
J’ai fait les mises à jour.

Bonne journée à vous

Salut @Zerko91 et bienvenue sur Gladys :slight_smile:

Tu as bien sélectionné le bon modèle de clé USB Zigbee dans Gladys ?

Tu as quoi comme logs dans Zigbee2mqtt ?

Pour afficher les logs :

docker logs gladys-z2m-zigbee2mqtt

Bonjour @pierre-gilles,
Merci pour ta réponse.
La clé est bien sélectionnée :

Voici le log :
Using ‹ /app/data › as data directory
Zigbee2MQTT:info 2023-09-19 06:37:57: Logging to console and directory: ‹ /app/d ata/log/2023-09-19.06-37-57 › filename: log.txt
Zigbee2MQTT:info 2023-09-19 06:37:57: Starting Zigbee2MQTT version 1.33.0 (comm it #7ee207f)
Zigbee2MQTT:info 2023-09-19 06:37:57: Starting zigbee-herdsman (0.18.5)
Zigbee2MQTT:error 2023-09-19 06:38:18: Error while starting zigbee-herdsman
Zigbee2MQTT:error 2023-09-19 06:38:18: Failed to start zigbee
Zigbee2MQTT:error 2023-09-19 06:38:18: Check https://www.zigbee2mqtt.io/guide/in stallation/20_zigbee2mqtt-fails-to-start.html for possible solutions
Zigbee2MQTT:error 2023-09-19 06:38:18: Exiting…
Zigbee2MQTT:error 2023-09-19 06:38:19: Error: Failed to connect to the adapter ( Error: SRSP - SYS - ping after 6000ms)
at ZStackAdapter.start (/app/node_modules/zigbee-herdsman/src/adapter/z-stac k/adapter/zStackAdapter.ts:103:27)
at Controller.start (/app/node_modules/zigbee-herdsman/src/controller/contro ller.ts:132:29)
at Zigbee.start (/app/lib/zigbee.ts:60:27)
at Controller.start (/app/lib/controller.ts:101:27)

Bonne journée.

Re-bonjour,
Ce qui m’interpelle c’est ça :


Quand je clique sur /dev/ttyACM0-ITEAD-1a86, ça me sélectionne /dev/ttyACM0

Cordialement.

Bonjour,

Pour être sûr de la bonne option à sélectionner, tu peux utiliser les commandes suivantes:

usb-devices

devrait retourner quelque chose comme ça

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=10c4 ProdID=ea60 Rev=01.00
S:  Manufacturer=ITead
S:  Product=Sonoff Zigbee 3.0 USB Dongle Plus
S:  SerialNumber=d65fba180f86ec11bfdf571719c2d21c
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#=0x0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=cp210x

Ce qui est important ici est :

  • Vendor=10c4
  • ProdID=ea60
  • Driver=cp210x

Ensuite, avec la commande :

dmesg | grep tty

tu auras une ligne de ce type là avec le driver (cp210x dans mon cas)

[    5.688245] usb 1-1.1: cp210x converter now attached to ttyUSB0

avec sûrement dans ton cas ttyACM0


Tu peux essayer aussi de débrancher/rebrancher ton Dongle et cliquer sur « Rafraîchir la liste des appareils USB »

:warning: à bien sélectionner le modèle du dongle. Le Son Off V3 a plusieurs versions:

Et pour ça, j’ai le même comportement (quand je sélectionne /dev/ttyUSB0 - ITead - 10c4, l’option résultante est /dev/ttyUSB0)

Et le Vendor 1a86 correspond à QinHeng, peut-être pas ton Dongle Zigbee.
Il y a peut-être besoin d’installer des drivers sur certains systèmes.

@cicoub13 ,
Merci pour ta réponse, voilà :
pi@gladys:~ $ usb-devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh= 1
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=1d6b ProdID=0002 Rev=06.01
S: Manufacturer=Linux 6.1.21-v8+ dwc_otg_hcd
S: Product=DWC OTG Controller
S: SerialNumber=3f980000.usb
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=0mA
I: If#=0x0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=480 MxCh= 5
D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=02 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=9514 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#=0x0 Alt= 1 #EPs= 1 Cls=09(hub ) Sub=00 Prot=02 Driver=hub

T: Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=ff(vend.) Sub=00 Prot=01 MxPS=64 #Cfgs= 1
P: Vendor=0424 ProdID=ec00 Rev=02.00
C: #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=2mA
I: If#=0x0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=ff Driver=smsc95xx

T: Bus=01 Lev=02 Prnt=02 Port=03 Cnt=02 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=02(commc) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=1a86 ProdID=55d4 Rev=04.42
S: Manufacturer=ITEAD
S: Product=SONOFF Zigbee 3.0 USB Dongle Plus V2
S: SerialNumber=20221202193210
C: #Ifs= 2 Cfg#= 1 Atr=a0 MxPwr=132mA

J’ai du mal à comprendre, j’ai acheté la clé chez Domadoo, je l’ai essayée sur Jeedom et Home assistant sans problème.
Cordialement.

Donc c’est bien ITEAD Vendor=1a86 mais je ne vois pas de driver utilisé :thinking:
Et c’est donc la version SONOFF Zigbee 3.0 USB Dongle Plus V2, modèle E

Es-ce que tu peux essayer de sélectionner
ITead Sonoff Zigbee 3.0 USB Dongle Plus V2 model "ZBDongle-E"
dans l’option du modèle ?
Puis, désactiver/activer dans Configuration ?

@cicoub13
Un grand merci, la coche est maintenant bonne.
Bonne fin de journée.
Cordialement.

3 Likes

4 Likes