Installation environnement de dev NodeJS et intergations

Bonjour,

Je suis en train d 'installer l’environnement de dev et j’ai deux questions :

  1. NodeJS 18 est obligatoire ? si on a la 20 ça ne marche pas ?
  2. Pour débuter c’est bien d’installer les intégrations si je veux voir un peu comment c’est foutu ? ou j’aurais quand même les dossiers et leur contenu, mais les dépendances ne seront pas chargées ?

Merci d’avance

Je pense que ça doit marcher en Node 20 en local, mais pour l’instant on ne le supporte pas officiellement ( On en parlait ici : Passage à NodeJS 20 )

Dans tous les cas les intégrations sont dans le repo, et quand tu fais npm install ça installe les dépendances des intégrations :slight_smile:

Après je te conseille quand même de mettre la variable INSTALL_SERVICES_SILENT_FAIL si tu ne développe pas sur Linux, car certaines dépendances linux-only auront sûrement du mal à s’installer :

(Cf doc: Mettre en place un environnement de développement sous Mac/Linux | Gladys Assistant )

Ce paramètre n’est qu’un flag pour dire que c’est ok si certaines dépendances d’intégrations ne sont pas correctement installée, vu que tu ne veux pas forcément avoir toutes les intégrations fonctionnelles en local.

Je connais pas grand chose mais j’ai plei d’erreur et rien ne se lancé dans les commandes.

J’ai mis la 18 et je verrais avec nvm plus tard

Ok, hésite pas à mettre les erreurs ici si tu veux de l’aide :slight_smile:

1 Like