Nouvelle vidéo YouTube: Utiliser le Zigbee dans Gladys avec une clé USB Zigbee

bon ca y est j’ai réussi a voir mon thermo oufff ,la première ois j’ai eu une erreur en me connectant sur le port 8080, et j’étais borné sur le fait que c’est Gladys qui gere tout , merci en tout cas pour votre patience , je suis tout excité maintenant de pouvoir connecter différents capteur

C’est tout le problème du “simple”

C’est en fait zigbee2mqtt qui utilise le dongle et gère la communication avec les périphériques. Mqtt sert de passerelle de communication entre zigbee2mqtt et gladys.

Content que ça soit résolu amuse toi bien.

Ps: lors de l’appairage d’un nouveau périphérique, zigbee2mqtt interroge le dit périphérique pour récupérer ses fonctionnalités, selon le modèle ça peut prendre 2 minutes.

ok merci , bon pour l’instant je n’est que la température d’affichée

@pascal_sapin As-tu fait quelque chose dans l’interface Zigbee2mqtt pour solutionner le problème ?

Je suis aussi intéressé par ton retour après intégration dans Gladys

Quelqu’un a déjà essayé une rallonge USB de 10m pour éloigner la clé USB Zigbee ?
Je n’arrive pas atteindre la boîte aux lettres de là où est mon Raspberry, qui est difficile à déplacer car branché sur un onduleur.

Sachant que c’est du Zigbee, tu peux aussi mettre des relais qui permettront au signal d’aller aussi loin.
Par exemple, tous les périphériques directement connectés en 220V sont généralement aussi des relais.

Mes prises électriques Zigbee sont des relais par défaut et permettent d’augmenter la portée du signal.

Dans ton cas je te conseillerais d’installer une prise 220V (ou autre chose pas sur pile) à mi chemin vers ta BaL et d’appareiller à nouveau ton capteur pour qu’il “s’attache” à ce relais.
J’ai fait exactement ça pour mon capteur de présence dans la BaL et ça fonctionne bien :slight_smile:

2 Likes

@gaetanb76 Par exemple cette prise connectée Zigbee fait relais:

1 Like

Exact, les ampoules philips le font toutes je crois

2 Likes

J’ai ajouté un lien dans la doc zigbee2mqtt vers le projet

2 Likes

Bonne idée @VonOx, merci pour la PR ! :slight_smile:

Bonjour,

Je viens de refaire mon installation gladys docker (avec le tuto) sur un raspberry ssd, et je n’arrive pas à associer mon dongle zigbee.


J’ai cette erreur dans les logs de mon container :

Le dongle fonctionnait bien sur mon ancienne installation. Quelqu’un aurait une idée du problème ?

Merci !

Tu as gardé l’image Gladys officielle ?

L’erreur est lié a docker je pense, qui ne semble pas avoir lancé le service zigbee, ou ne le trouve pas.

Bullseye n’est pas fonctionnel ( bug identifié)

Prend l’image officielle gladys

Ou, j’ai lancé l’image officielle dans docker.
Le service zigbee ne veut pas se lancer tant que je n’ai pas déclaré sur quel port est branché la clé zigbee, mais même en choisissant le bon port, ça me met le message d’erreur. Je vais essayer de réinstaller dans un autre container.

Je parlais de l’image raspberry, tu as pris laquelle ?

Bullseye … Le problème est donc là ? Il vaut mieux prendre un debian buster ?

Oui, des services intégrés à Bullseye ont été mis à jour, mais certains apportent des changements majeurs qui perturbent le fonctionnement de Gladys. Pour le moment il faut rester sur Buster.

1 Like

Incroyable je sais pas si c’est vous mais j’en ai tellement parlé de ce dongle qu’il est maintenant en rupture de stock chez Domadoo ! (enfin une semaine d’attente)

2 Likes

Problème réglé sur buster