Pouvoir tourner une image de caméra à 180°

Bonjour a tous
Je rencontre un problème avec une camera et le dashboard. Je suis obliger de suspendre ma camera tête en bas et donc j’inverse l’image pour la voir à l’endroit. Mais dans le dashboard elle s’affiche à l’envers, est ce qu’il y aurait un moyen de retourner l’image sur le dashboard. Ou y a t-il un autre moyen ?
merci pour vos reponses

Merci VoxOn,
D’avoir créé un nouveau topic, comme on parlait de camera dans celui la j’ai ecris la, mais c’est vrai qu’il etait un peu ancien.
Bonne fin d’apres midi

De rien, tu utilises quoi comme caméra ?

Bonsoir VonOx
J’ai actuellement une Foscam f18910w ,(fonctionne en parallèle avec l’appli smartphone(
une Kerui Z05H-20, (ne fonctionne pas quand elle est gerée par un appli )
une camera recuperée d’un vieux systeme SFR sfr RC8221W v2. (pas d’appli dispo)
J’ai un portier vidéo Konx2c , mais comme la Kerui, je n’arrive pas à récupérer le flux vidéo, lorsqu’elles sont déclarer dans mon appli Yosee. Et j’essaye aussi une Esp32Cam, mais je n’arrive pas non plus à récupérer le flux vidéo, j’ai lu que le flux vidéo de l’esp32cam était haché et que ça viendrait de ça.
Bonne soirée

C’est une fonctionnalité qui pourrait être ajoutée (genre un paramètre à la caméra: rotation: 180°) !

J’avoue que tu es le premier à demander :smiley:

On pourrait transformer ce post en demande de fonctionnalité peut-être?

Bonjour Pierre Gilles,

moi ça m’irai bien
Merci

J’ai transformé ce post en demande de fonctionnalités, maintenant il faut voter :slight_smile:

Comme il y a des centaines de demandes, on priorise avec le nombre de votes !

Pas de soucis ,c 'est la regle.
Merci :wink:

1 Like

Le code côté server est terminée

Ma cave la tête en bas :slight_smile:
image

Je peaufine l’interface

1 Like

Super, je vais pouvoir voir mon jardin à l’endroit? :grinning: :grinning:
Merci VonOx
Bon week-end

1 Like

J’ai juste un petit soucis , si des devs confirmés peuvent m’aider :sweat_smile:

Il doit y avoir un bug dans ton code, tu as des erreurs dans la console de ton navigateur ?

Auncun doute ! :smiley:

Non j’ai rien, me suis même mis des console.log en mode cowboy pour vérifier les valeurs.
image

D’ailleurs je comprends pas pourquoi le log affiche 2 lignes, bref j’ai toujours un peu de mal avec le front.

Ok, je lance ta PR en locale pour voir

Déjà juste lancer ta PR avec ma DB existante ça plante l’UI:

Ce que j’en comprends c’est que le paramètre n’existe pas sur ta DB et que je dois gérer ce cas ( tu me rajoute des problèmes ^^ )

Je pense pas que le paramètre devrait être précisé pour toutes les caméras!

Le paramètre devrait être là que pour les caméras qui nécessitent une rotation, sinon ça devrait marcher même si le paramètre n’existe pas en DB :slight_smile: