Relevé de bugs divers

@Jean34 Je confirme que j’ai corrigé ton bug avec la box météo + appareils de la pièce :slight_smile:

ça partira dans la prochaine release de Gladys, une fois que suffisamment de membres auront testé l’image de dev :slight_smile: (j’en fais une soon!)

1 Like

@pierre-gilles c’est bon aussi en 4.0.9 depuis le conteneur

image

Pour le timeout j’ai rien touché, la découverte est instantané donc je sais pas. je vais augmenter pour voir.

Edit: Timeout à 10 secondes => OK

Ah! Donc c’est bien un problème de timeout ? :slight_smile:

Je vais le changer du coup

Edit:

1 Like

Ouai on dirait que c’est ça même si j’explique pas pourquoi ça prends plus de temps côté gladys :thinking:

J’ai lancé un build dev avec tous les fixs récents

Le build dev est disponible, je suis preneur de tout retour sur ce build, ça serait cool qu’on soit sûr qu’il n’y a pas de régressions cette fois-ci ^^

J’ai fais pas mal de tests de mon côté (autant manuel qu’automatisé comme toujours), mais n’ayant pas le même matos que vous, je ne peux pas tout tester en réelle.

1 Like

Est ce qu’il y aurait une commande que je puisse faire en ssh afin de tester si cela fonctionne?

@pierre-gilles au top, je vais essayer de trouver un peu de temps pour aussi tester la dernière release dev, j’ai que le dimanche de repose ces temps-ci alors je promets rien…

@Tlse-vins si tu parles de l’image dev, si je ne dit pas de bêtise, tu executes la ligne de commande docker qui se trouve dans la doc, tu ajoutes le tag dev et renomme la db. Où bien tu git pull si tu as un environnement de développement.

Non je suis sur une image en prod sur un Raspberry.

@Tlse-vins j’ai aussi une instance de prod, mais rien n’empêche de tester une instance de dev, perso je fais comme ceci :
docker stop gladys

docker run -d --log-opt max-size=10m --restart=always --privileged --network=host --name gladysdev -e NODE_ENV=production -e SERVER_PORT=80 -e TZ=Europe/Paris -e SQLITE_FILE_PATH=/var/lib/gladysassistantdev/gladys-dev.db -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/gladysassistantdev:/var/lib/gladysassistantdev -v /dev:/dev -v /run/udev:/run/udev:ro gladysassistant/gladys:dev

@pierre-gilles, mon installation étant fraiche je reviens vers toi pour un éventuel bug…
Donc une fois que gladys est installé, je configure par exemple la météo et ensuite, je demande via le chat, quelle température il fait. Sur le moment elle ne répond pas, donc je regarde les logs, coté docker ya rien d’anormale mais coté navigateur si :

    close { target: WebSocket, isTrusted: true, wasClean: true, code: 1001, reason: "", srcElement: WebSocket, currentTarget: WebSocket, eventPhase: 2, bubbles: false, cancelable: false, … }
​
bubbles: false
​
cancelBubble: false
​
cancelable: false
​
code: 1001
​
composed: false
​
currentTarget: null
​
defaultPrevented: false
​
eventPhase: 0
​
explicitOriginalTarget: WebSocket { url: "ws://192.168.1.82/", readyState: 3, bufferedAmount: 0, … }
​
isTrusted: true
​
originalTarget: WebSocket { url: "ws://192.168.1.82/", readyState: 3, bufferedAmount: 0, … }
​
reason: ""
​
returnValue: true
​
srcElement: WebSocket { url: "ws://192.168.1.82/", readyState: 3, bufferedAmount: 0, … }
​
target: WebSocket { url: "ws://192.168.1.82/", readyState: 3, bufferedAmount: 0, … }
​
timeStamp: 266627
​
type: "close"
​
wasClean: true
​
<get isTrusted()>: function isTrusted()
​
<prototype>: CloseEventPrototype { wasClean: Getter, code: Getter, reason: Getter, … }
​​
code: 
​​
constructor: function ()
​​
reason: 
​​
wasClean: 
​​
Symbol(Symbol.toStringTag): "CloseEvent"
​​
<get code()>: function code()
​​
<get reason()>: function reason()
​​
<get wasClean()>: function wasClean()
​​
<prototype>: EventPrototype { composedPath: composedPath(), stopPropagation: stopPropagation(), stopImmediatePropagation: stopImmediatePropagation(), … }
Session.js:60:6

Si je rafraîchis ma page (très longue au chargement d’ailleurs), la réponse de gladys est bien là, souvent au-dessus de ma question, mais elle est là ^^. Après plus de soucis, on peut lui parler autant qu’on veut, elle répond tout de suite.
Voilà, si ça peut aider :slight_smile:

@Jean34 Ok, merci pour ton retour :slight_smile:

J’ai créé une issue pour ne pas perdre le bug:

Hello,
J’ai un bug au niveau du chat. Quand j’écris le mot “météo” mon Gladys plante et je suis obligé de force restart.

Il me semble pas que ce soit un comportement normal donc je pose ça ici :slight_smile:

Je suis sur la version 4.3.1 et aucunes erreurs dans les logs ou dans la console.

Rectification, à partir du moment où j’envoie n’importe quel mot ou phrase dans Gladys ça plante.

Tu as plus de détails @JeuFore ?

Chez moi ça fonctionne, j’aimerais en savoir plus sur ton installation !

Tu as installé Gladys avec l’image raspberry pi OS officielle ?

J’ai un Raspberry pi 4 4go avec Ubuntu Server arm64 d’installé. Du coup, Gladys a été installée à la main.

La DB de l’instance est save sur un disque dur.

Gladys tourne très bien mise à part le chat.
Je sais que avant la nouvelle mise à jour, le chat marchait, mais il fallait que je refresh la page pour avoir la réponse.

Quand tu dis « Gladys a été installé à la main », via docker on est d’accord ?

Tu as utilisée la commande docker run fournie sur le site Gladys ?

A pardon je me suis mal exprimé :sweat_smile:

Oui via docker, j’ai repris le docker run est mis dans un docker-compose

version: "3"
services:
  app:
    image: gladysassistant/gladys
    container_name: gladys
    network_mode: host
    environment:
      - SQLITE_FILE_PATH=/var/lib/gladysassistant/gladys-production.db
      - SERVER_PORT=2380
      - TZ=Europe/Paris
    privileged: true
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - /run/udev:/run/udev:ro
      - /dev:/dev
      - ~/disk/docker/appdata/gladys:/var/lib/gladysassistant
    restart: unless-stopped

Salut,

N’est-ce pas lié à mon précédent message ?

@Jean34 je pense pas, la il dit carrément que Gladys crash, ça m’étonne :sweat_smile:

@JeuFore donc on est d’accord le bug c’est:

  • tu envoie n’importe quel message à Gladys
  • Gladys plante et le container redémarre

Tu n’as vraiment pas de logs dans Gladys? Parce qu’un crash ça passe pas inaperçu en général

Exactement, sauf que c’est moi qui redémarre le container.

Et je viens de re tester, j’ai aucun log que ça soit dans le navigateur ou sur le container.

Je viens aussi de test si il y a une différence entre l’adresse ip local et l’accès à distance (nginx + ssl), mais le même crash survient.

@JeuFore J’ai pas de réponse à te donner, pour le coup je sèche complet! D’intuition, vu qu’on ne voit vraiment rien, que le bug n’apparait que chez toi, est-ce que ça ne pourrait pas être une corruption de carte SD? Tu dis que la DB de l’instance est sur un disque dur, par contre Docker, et les images, elles sont sur la SD?