ZigBee2mqtt HS depuis longtemps

Bonjour,
Cela fait longtemps que ZigBee ne fonctionne plus.
J’avais laissé tombé et ai décidé de m’y remettre.
Pb rencontré :
Les conteneurs démarrent, mais la connexion MQTT - ZIGBEE2MQTT ne se fait pas dans l’interface.
J’ai fait plusieurs fois la manip suivante, sans succès :

  • désactiver le service dans Gladys > Configuration
  • débrancher la clé
  • supprimer les conteneurs :
    docker stop gladys-z2m-zigbee2mqtt
    docker stop gladys-z2m-mqtt
    docker rm gladys-z2m-zigbee2mqtt
    docker rm gladys-z2m-mqtt
  • stopper le conteneur gladys :
    docker stop gladys
  • vérifier l’état des conteneurs
    docker ps -a
  • supprimer la conf :
    sudo rm -rf /var/lib/gladysassistant/zigbee2mqtt
  • redémarrer gladys
    docker start gladys
  • rebrancher le dongle
  • connecter le dongle dans Gladys > Paramètres /dev/ttyUSB0
  • sauvegarder
  • activer le service dans Gladys > Configuration > Activer Zigbee2mqtt
  • attendre longtemps (20 minutes)
    Mais le lien reste tjs avec une croix rouge

J’ai fait un sudo reboot, mais cela n’a rien changé.

Des idées ?

Edit :

docker logs gladys-z2m-zigbee2mqtt

Donne plein de fois, avec le FailureMessage Object qui change :

Using ‹ /app/data › as data directory

Fatal error in , line 0
unreachable code

FailureMessage Object: 0x7efce64c
Using ‹ /app/data › as data directory

J’ai cherché ce message d’erreur sur Google, je tombe sur ça:

Qui me renvoie sur ça:

Il y a eu un souci sur Zigbee2mqtt en début d’année pour les utilisateurs sous Raspberry Pi, et il faut faire une manipulation pour fixer ça. On y peut rien côté Gladys :slight_smile:

Salut @pierre-gilles,
Merci pour l’info.

Je viens de faire ce qui est indiqué sur le site :sweat_smile:, puis
docker restart gladys-z2m-zigbee2mqtt
Ensuite actualisation de la page de config du service Zigbee2mqtt
et toutes les coches sont vertes :hugs: :blush:

2 Likes