Problème de connexion à Enedis

Bonjour,
C’est ma première intégration d’Enedis (je débute avec Gladys). J’ai bien suivi le tutoriel, j’ai bien synchronisé Gladys (2 fois, car apparemment d’après Pierre-Gilles ça ne fonctionnait pas la première fois).
Malgré, cette deuxième tentative et réception du second mail d’acceptation du partage par Enedis, je n’ai encore reçu aucune donnée.
D’avance merci pour vos conseils
Daniel

Salut @Janssens, de mon côté c’est toujours pareil j’ai une erreur comme quoi le consentement n’est pas bon.

Est-ce que tu peux me montrer ce que tu fais quand tu connecte Enedis à Gladys ? (pense à masquer tes informations personnelles)

Quand as-tu activé le service de retention des données Enedis ?

Côté EDF, tu vois bien tes courbes de consommations historiques ?

Bonjour Pierre-Gilles,
Désolé de t’emm…der avec mes problèmes.
Tu trouveras étape par étape la procédure suivie.
J’ai activé le service de rétention Enedis une première fois ce dimanche 26 vers 20 h, ensuite le lundi 27 vers 19h et enfin aujourd’hui un peu avant 18 h.
Pour ces 3 demandes, j’ai reçu dans les minutes qui ont suivies un mail d’enedis (voir dernière photo)
A ce jour, je n’ai reçu aucune information de consommation (voir le widget)





E5

Voici la copie du mail retour d’Enedis

Et côté Enedis (ton portail EDF), tu vois bien ta consommation ?

Tu t’es trompé de box sur le tableau de bord.
Ce n’est pas appareil que tu dois choisir mais graphique
image

Voila l’extrait de la doc

Et sur le site Enedis, tu vois tes relevés de consommation?
Après il y a peut être un problème de synchro aussi. Mais en ce moment le service fonctionne bien.

Un grand merci pour ta réponse. Je vois bien mes consommations sur le site d’Enedis. Je viens de modifier (graphique à la place d’appareil) la box du TDB.
J’attends demain pour voir les infos.
Décidément, il faut que j’apprenne à lire :slight_smile: correctement.
Désolé pour le dérangement.
Daniel

Avec plaisir.
N’hésites pas si tu as d’autres questions

Salut @Janssens !

Peut tu me montrer une capture d’écran de ta consommation électrique sur le site EDF ? (en masquant tes informations)

Côté Gladys Plus, j’ai toujours le même message pour ton compte : « No consent can be found for this customer and this usage point. »

Désolé mais il va falloir refaire le consentement en cliquant sur le bouton Enedis dans Gladys Plus…

Est-ce qu’il y a quelque chose de spécial dans ton compte qui pourrait expliquer cela ?

Si ça ne marche toujours pas après ça, on pourra s’appeler si tu veux pour que tu me montres en partage d’écran ce que tu fais :slight_smile:

C’est aussi entièrement possible que ni toi ni moi ne sommes responsable, l’API d’Enedis est très capricieuse et fonctionne quand elle veut ^^ On a eu des indisponibilités de certaines routes d’API pendant des semaines sans explications de leur part…

Merci Pierre-Gilles pour tes conseils.
Tu trouveras, ci-joint le graphique de mes données sur le site d’Enedis. La seule explication pour ma problématique, qui me semble personnelle est :
Je suis Belge (nul n’est parfait :slight_smile: ) et je prépare Gladys mon l’installation pour ma seconde résidence en France → Actuellement Gladys se trouve en Belgique, est-il possible q’Enedis bloque les infos à destination d’un autre pays ?
Mise à part cette explication, je ne vois pas d’autres raisons « objectives » a mon problème.

@Janssens Le problème ne vient pas de toi mais d’Enedis malheureusement, c’est un bug qui est apparu le 5 mars ( Problème avec l'intégration Enedis - #17 par pierre-gilles ), qui a été réglé le 22 avril ( Problème avec l'intégration Enedis - #21 par pierre-gilles ), et qui vient de revenir.

J’ai transmis les informations à Enedis, je te tiens au courant.

Je vais voir si je peux pas faire des adaptations de mon côté pour qu’on puisse se passer de cette route d’API qui n’est clairement pas stable malheureusement… :confused:

1000 merci Pierre-Gilles pour ta réactivité. Pour ma part, très égoïstement, je ne suis pas pressé. Fais pour le mieux.

Très bonne fin de journée

1 Like

@Janssens Enedis vient de me confirmer que le souci vient de leur côté :

J’ai envoyé toutes les informations nécessaires pour qu’ils puissent débugger.

Je te tiens au courant

Un tout grand merci. Très bonne journée
Daniel

1 Like

Je commençais à en avoir marre de la route d’API Enedis qui ne fonctionne qu’une fois sur deux, donc j’ai modifié le code de Gladys Plus pour s’en passer quand elle ne fonctionne pas, et ça marche !

@Janssens J’ai testé avec ton compte, ça règle le souci ! Tu devrais récupérer dans Gladys toutes tes données de consommation électrique, si ce n’est pas le cas tu peux cliquer sur ce bouton dans l’interface de Gladys Plus pour bien tout rapatrier.

Tiens moi au courant :slight_smile:

1 Like

Bonsoir Pierre-Gilles,
Un immense merci pour ton travail et ta pugnacité. Je pense que ça fonctionne. Voici la synchronisation en cours

1 Like

Génial, ça fait plaisir à lire :slight_smile:

Merci pour ta patience, et n’hésite pas si tu as d’autres soucis !

Pour confirmer mon dernier post.
Ca fait plaisir.
ED2

@Janssens je te conseille de passer en mode histogramme, c’est plus visuel pour l’électricité :slight_smile:

Merci pour cette information. Bonne soirée