Relevé de bugs divers

T’embête pas avec une réinstallation, ça ne changera rien à mon avis.

Les services non plus, ça n’a pas de lien. Je peux éventuellement rajouter plus de logs dans le front pour qu’on puisse mieux diagnostiquer le problème :slight_smile:

Pour information, je viens de lancer un build dev avec pas mal de petits fix/des nouveaux périphériques Zigbee2mqtt :slight_smile:

@Jean34 pour ton problème je vais enquêter de mon côté et voir ce qu’on pourrait tester. J’ai une piste! Ne réinstalle pas, ça ne changera rien. A mon avis c’est un bug interne à Gladys.

Par curiosité, quelles box as tu sur ton écran d’accueil ? La liste complète :slight_smile:

@Jean34 J’ai trouvé! C’est un problème tout simple, qui n’est pas spécifique à Gladys Plus (il apparait aussi dans Gladys, mais moins facilement car c’est une race-condition)

J’ai créé une issue GitHub, je te tiens au courant dès qu’un correctif est live:

Si tu veux vérifier ma théorie, retire la box “météo” du dashboard, enregistre et sauvegarde la page. Tu verras normalement ça marche :slight_smile:

1 Like

C’est bien ça :+1: tout fonctionne maintenant. Je file mon chef gueule :grin:

Ok top. Ça sera corrigé dans une prochaine release :slight_smile:

1 Like

Je viens de me rendre compte que l’intégration Philipps Hue ne fonctionne plus.
Je suis repartie d’une instance neuve, avec la nouvelle image. Donc je suis en 4.3.0.
L’intégration ne trouve pas le pont. Et j’ai vérifié il.est bien dans mon réseau et accessible.

La façon de détecter le pont à été changé récemment, avant on faisait un N-uPnP search et maintenant on fait un uPnP search. Ca a été changé car chez certaines personnes l’intégration ne fonctionnait pas avant.

Mais normalement ça devrait fonctionner autant qu’avant, voir mieux…

Tu as un pont quel génération ?

D’autres gens ici ont le problème ou Philips Hue fonctionne ?

Je ne sais pas trop ce que ça veux dire.
Est ce que l’on peux faire les 2?

J’ai celui-ci :


Le “N-UpNp search” en gros ça utilise le cloud philips hue pour aller chercher la liste des bridges disponibles sur un réseau précis.

  • L’avantage c’est que c’est rapide
  • L’inconvénient c’est que ça ne fonctionne pas avec tous les bridges et c’est dépendant du cloud Philips hue. ça ne fonctionne que si tu as internet aussi, ce n’est pas “local only”.

Le “UpNp search” en gros c’est un scan réseau. C’est pur local, pas dépendant du cloud.

On a décidé de passer au UpnP search pour justement ne plus être dépendant de Philips et permettre à tous d’utiliser philips hue. Après je ne pensais pas que ça ne marcherait pas sur certaines installations. Il y avait eu des tests chez différents utilisateurs avant la release et ça fonctionnait chez eux. Tu as une spécificité réseau chez toi qui ferait qu’un scan réseau ne serait pas possible?

C’est pas bête! Pourquoi pas rajouter l’ancienne option.

Juste pour confirmer que ça marche en N-UpNp chez toi, tu peux ouvrir le lien suivant dans ton navigateur, depuis chez toi en Wi-Fi: https://discovery.meethue.com/

En se basant sur l’IP de ta box ça te renverra la liste des bridges vu sur ton réseau par le Cloud Philips Hue.

Rien de particulier sur mon réseau, configuration normal. Une box, et le Pi.
Je regarde ça ce soir et je te tiens au courant.
Depuis quelle version il y a eu ce changement ?
Je n’avais pas rencontré ce problème avant.

La détection ne fonctionne plus non plus chez moi

Chez moi ça fonctionne toujours via le réseau local

Summary

Mais pas via Gladys Plus.

Renvoi bien les infos des Bridges sur le réseau local.

Depuis la 4.2.0, sortie le 1er avril => Gladys/CHANGELOG.md at master · GladysAssistant/Gladys · GitHub

@VonOx est-ce que ça pourrait pas venir de la nouvelle image Raspberry Pi OS ? (je vois pas pourquoi ça viendrait de là mais bon…)

Parce que si ça fonctionne chez @Terdious (qui à mon avis est sur une image Raspberry Pi OS plus ancienne), alors que @Tlse-vins et toi êtes sur la nouvelle image?

Je confirme pour ma part être sur l’ancienne image.

Non je ne suis pas sur rpi, faut trouver le point commun :sweat_smile:

D’ailleurs je n’ai jamais fais tourner Gladys sur rpi en prod

Moi j’ai rien:

@Tlse-vins !! Mmmh bah si du coup, c’est censé être l’id et l’adresse ip de ton bridge sur la photo que tu as envoyé au format JSON.

Je pensais voir une autre interface.
C’est bien l’adresse Ip de mon pont Hue.
C’est moins pire, non ?

@VonOx tu as moyen d’enquêter chez toi vu que tu as le problème ?

Voir si Docker n’empêche pas le scan réseau par exemple?

Tu teste en local sur ton laptop voir si ça marche (hors docker)

De mon côté j’ai créé une issue pour rajouter le N-UpNp search en plus du UPNP search pour qu’on ait les deux :slight_smile: je ferais ça en mode smart, il faut pas que ça fail si l’utilisateur a pas internet, le N-Upnp search ne doit être qu’un complément:

Use N-UpNp search + UPnP search on Phillips Hue bridge search · Issue #1180 · GladysAssistant/Gladys · GitHub

Oui il faut que je trouve un peu de temps pour ça.

Hors docker

J’ai testé le package npm en direct sur 2 machines avec les 2 méthode nupnpsearch et upnpsearch

Même test mais depuis le conteneur Gladys

Donc c’est Gladys qui déconne ou le package en 4.0.9

Mes tests ont été fait en 5.0.0-beta.2