Détection de présence via le réseau local

J’ai aussi dû désactiver les autres CIDR à scanner pour que ça fonctionne…

1 Like

Le bouton est rouge :smiley:
Je vais voir pour ajouter une animation sur le bouton, sans alourdir le tout.

Euh… bonjour :smiley: non ça me dit rien… maintenant si tu joues un peu avec l’invite de commande, tu peux tenter avec la commande nmap -sn 192.168.1.1/24 (en adaptant l’IP avec celle de ton réseau).
Si tu vois ton iPhone ici, c’est un bug sur le service Gladys.
Si tu ne vois pas l’iPhone, ça peut venir de ta machine, du routeur, du réseau, de l’iPhone…

Hum… une histoire de cache sur le réseau ?
La même que pour @spencer, si tu joues un peu avec l’invite de commande, déconnecte ton smartphone du WiFi, attend 1 minute (en général il y a un cache sur le routeur), essaie un nmap -sn 192.168.1.1/24 (en adaptant l’IP avec celle de ton réseau).
Si tu ne vois plus ton device, c’est un problème avec le service.
Si tu le vois encore, ça peut venir de ta machine, du routeur, du réseau (mais pas du smartphone)…

Merci, je vais désactiver les interfaces « trop gourmandes » par défaut.

2 Likes

Ah il est censé changé de couleur xD ?
Che moi il est tjrs rouge :-s

1 Like

C’est que le scan ne s’arrête pas.
Change la configuration des interfaces (limites aux IP qui t’interessent) et redémarre ton instance Gladys… On va éviter que ça prenne feu durant la nuit :smiley: (blague).

Je suis en train de mettre en place un limiteur en durée pour le scan.
Mais il n’y aura pas de « petite roue qui tourne » sur le bouton, le dev est « trop couteux ».
On va faire en sorte qu’il revienne bleu, après le rouge :wink:

J’ai essayé la commande nmap et cela fonctionne bien. Quand je connecte le téléphone au wifi il est dans la liste nmap, si je le déconnecte il n’apparait plus.

Par contre dans Gladys :smiling_face_with_tear:. J’ai redémarré Gladys et maintenant il ne trouve plus rien

1 Like

J’ai redemarré une seconde fois et j’ai eu un msg d’erreur

Dans les logs la commande nmap a portant l’air d’avoir fonctionné

EDIT: après rafraîchissement de la page la liste est apparue

EDIT 2:
Après ce second redémarrage de Gladys cela se comporte mieux dans l’affichage et la détection de mon téléphone sur le tableau de bord. Bizarre.

A suivre je continuerais des tests demain avec d’autres appareils

1 Like

Pas de souci :slight_smile:

Il n’y a pas de timeout sur un scan ? Je pense qu’au delà de 60 secondes de scan ça sert à rien, il faut couper. Sinon on risque d’avoir des process qui s’accumule à l’infini

Il n’y a pas d’indicateur qu’une synchronisation est en cours ? Un petit spinner + un petit message serait le bienvenue, sinon c’est très frustrant pour l’utilisateur, il ne sait pas ce qui se passe.

2 Likes

Hello !
Bon mauvaise nouvelle, il apparait bien sur la commande nmap, en revanche, sans qu’il ne bouge, il est apparu sur 4 scan sur 5.

Salut,

perso il a réussi à le trouver, je m’en suis rendu compte par hasard.
J’ai viré toutes les adresses sauf ma locale mais il ne voit plus rien.

J’ai beau avoir ajouté mon tel, il me dit qu’il ne m’a pas vu depuis 10h…

@AlexTrovato ce matin tout a l’air de fonctionner suite au redémarrage de Gladys hier soir. J’ai ajouté d’autres appareils ce matin et cela fonctionne correctement.

@AlexTrovato Au premier scan, j’ai eu une alerte de mon PiHole me disant qu’il avait bloqué Gladys en raison d’un trop grand nombre de requêtes (+de 10000).
Peut-être que certaines box ont cette même limite nativement, d’où l’intérêt effectivement de limiter au réseau de base…

1 Like

Petit souci et aucune idée de ce que c’est…
Hier, j’avais trois autres réseaux (aucune idée de ce qu’ils font là).
Après désactivation, le service fonctionnait.
Cette après-midi, trois réseaux supplémentaires sont apparus, activés par défaut et scan interminable…


Et je pense que l’icône ‹ poubelle › n’a pas d’effet…

Les scan ne se cumulent pas, pour lancer un nouveau scan, il faut que le service ne soit pas déjà en train de scanner… mais s’il ne termine pas, c’est génant.
Je vais mettre en place le « timeout » asap.

Je vais tenter de faire un truc propre, mais ce ne sera pas priorité. Le bouton « démarrer scan » passe de bleu à rouge, comme sur le Bluetooth, il n’y a juste pas d’animation.

Il va falloir trouver le moyen d’identifier ces réseaux… apparemment ce sont des interfaces réseau virtuelles…

Alors, work in progress :slight_smile:

Pour les smartphones, je pense que le fait de corriger le scan « infini » aidera à y voir plus clair.

2 Likes

J’ai oublié, sur un navigateur, la poubelle affiche un message signalant qu’on ne peut pas supprimer une interface réseau.

J’y vois d’ailleurs une typo…

Pour info, je suis en train de générer une image nouvelle docker (atrovato/gladys:lan-manager disponible d’ici 1 heure) avec les correctifs… j’ai pas testé en réel :slight_smile:

Je ne suis pas sûr d’avoir le temps de tester d’ici le weekend, donc si un courageux sait reproduire le(s) problème(s) (surtout le scan infini et les IPs docker/veth qui doivent être désactivée par défaut), je suis preneur.

Pensez à préserver votre db de production en faisant les tests sur une autre machine que celle de votre installation Gladys (ou maîtrisez les backup DB).

Sur ce, bonne soirée :wink:

2 Likes

Hello @AlexTrovato
Je te remonte un nouveau bug lorsque quon decoche loption cacher les appareils ajouté.
Jai une duplication du premier appareil qui saffiche est ce normal ?
Jai encore 3 fois ça tjrs avdc la meme mac:

Top ! Pour info la lib a un paramètre « scanTimeout » donc c’est vraiment pas compliqué à mettre en place :

2 possibilités assez simple à mettre en place :

  • Soit tu mets la page en « loading » comme on fait partout avec le spinner

Je parle de cette classe:

  • Soit tu mets un « alert alert-primary » avec un message « Un scan est actuellement en cours… »

C’est ce que j’avais fait au début, mais avec le scan auto, toutes les 2 minutes, d’une durée de 1 minute, l’utilisateur n’a pas le temps de faire ce qu’il veut que la page est à nouveau bloquée pour être rechargée.

Sur l’image officielle ou celle de test ?
Non ce n’est pas normal.
Si tu sais le reproduire, note bien comment faire.
Si je peux le reproduire de mon côté, je peux le corriger.

Sur limage officiel actuellement je lai a chaque fois que je decoche l’option cacher

  1. scanner
  2. ajouter device
  3. decocher options
  4. magie plein de doublon dans l’onglet decouverte

Je ne fais rien de particulier ^^

Ok je vois, dans ce cas le « alert alert-primary » en haut de la page peut-être une option